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Chapter 40: MIDI Tool

MIDI Tool 
What it does
This tool lets you edit the actual MIDI data that Finale stores with your music—key velocities 
(how hard each note was struck), Start and Stop Times (rhythmic information), channel pressure 
(pressure applied to a key after it’s been struck), controller data (pedaling, modulation wheel 
usage, and so on), pitch bend information, and patch change events. When you click the tool, the 
MIDI Tool Menu appears, containing all the commands you need to increase, decrease, or gradu-
ally change any of these data types.

To use the MIDI Tool, you begin by selecting a region of music whose MIDI information you 
want to edit; you then choose commands from the MIDI Tool Menu. If you only want to affect a 
one-staff region that fits on the screen, you can double-click the selected region to enter the MIDI 
Tool split-window, where you can view a graphic representation of the MIDI values you’re edit-
ing. Using this technique, you can edit MIDI data on a note-by-note basis—for example, you can 
increase the key velocity of only certain notes in a chordal passage.

To enter bank and program change data from the MIDI Tool, follow the procedure for entering 
patch changes. Remember, a patch is a combination of bank and program information. See 
PATCHES.

To send bank and program changes immediately, enter the program change and bank select values 
into the modified Send MIDI Value dialog box (choose Send MIDI Value from the MIDI Menu). 
Sending controller data is simple. To choose a controller, click Controller, then choose the name 
of the controller, such as 64:Sustain Pedal, from the Controller drop-down list.

Other effects you can create with the MIDI Tool include inserting and editing pitch bends, creat-
ing smooth crescendos and decrescendos, creating true swing-feel playback, randomizing certain 
playback variables to create a more human feel, and so on. See SEND MIDI VALUE DIALOG BOX, 
PITCH WHEEL, CRESCENDO/DECRESCENDO, SWING, and PLAYBACK.

Special mouse clicks
• Click a measure to select it.

• Drag-enclose several measures to select more than one.

• Shift-click (or shift–drag-enclose) a measure (or measures) to extend the selected region 
from the first measures you selected.

• Click to the left of a staff to select an entire staff.

• Shift-click to the left of a staff to extend the selection from any other staves you’ve selected.

• Double-click the highlighted area to display the Midi Tool split-window for the top selected 
staff.
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MIDI Tool Menu
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p.

What it does
When you record a real-time performance with the Transcription Mode of HyperScribe, you can 
tell Finale to remember the precise feel of your original performance, and to keep this captured 
MIDI data handy for playback once you return to the score. For full instructions, see TRANSCRIB-

ING A SEQUENCE.

This captured data includes key velocity information (how hard you struck each key); Note Dura-
tion data (minor deviations from the beat that result in swing, rolled chords, rushing the beat, and 
so on); and Continuous data (MIDI controller information you generated during your perfor-
mance such as pedal and pitch wheel usage, patch changes, monophonic aftertouch, and so on).

Once you’ve transcribed your performance into standard notation, you can listen to it play back in 
one of two ways. You can listen to Finale play it exactly as it appears in the score—expressionless 
and rhythmically perfect; or, if you prefer, you can listen to it using the captured MIDI data so that 
it retains the nuances of your original performance. (See PLAYBACK for full instructions on speci-
fying the method of playback you want to use.)

The purpose of the MIDI Tool is to edit the captured MIDI data. You can make a passage louder or 
softer, create a swing feel in one section, edit the pedaling, insert a patch change, modify a pitch 
bend, and so on. The commands in the MIDI Tool Menu let you edit the captured MIDI data in 
various ways.

There are two ways to select the section of your notated score whose captured MIDI data you 
want to edit. Click the MIDI Tool. If the region is large, select the measures exactly as you would 
with the Mass Mover Tool: Click to select one measure, shift-click to select additional measures, 
drag-enclose to select several on-screen measures, click to the left of the staff to select the entire 
staff, or choose Select All from the Edit Menu to select the entire document. Then simply choose 
the appropriate commands from the MIDI Tool Menu to affect all the selected measures at once.

If the music whose MIDI data you want to edit is a one-staff region that fits on the screen, select it 
in the usual way, then double-click the highlighted area. You enter the MIDI Tool split-window, 
where you can see the MIDI data represented graphically. Once in the MIDI Tool split-window 
you can also specify the MIDI data—the key velocity, for example—of individual notes, even if 
they’re buried within chords, by selecting their handles; see MIDI TOOL SPLIT-WINDOW.

Once you’ve edited MIDI data (and returned to the score), you can then erase it, or copy it from 
one passage to another in the same way you’d use the Mass Mover Tool to copy music. Be sure 
the MIDI data type you want to manipulate is selected in the MIDI Tool Menu; select the source 
measures just as you did before. If the measures to which you want to copy the selected MIDI 
information are visible on-screen, drag the first selected measure so that it’s superimposed on the 
first target measure. If the target measures are offscreen, scroll so that you can see the first one; 
then, while pressing ctrl and shift, click the first target measure. In either case, the Finale copies 
the MIDI data from the source measures to the target measures.
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To erase the captured MIDI data from a region, be sure the MIDI data type you want to manipu-
late is selected in the MIDI Tool Menu; select the source measures just as you did before, and 
press backspace. Only the data type specified in the menu (Key Velocities, Note Durations, or 
Continuous Data) will be cleared from the selected region. 

For a complete tutorial in the use of the MIDI Tool, see Installations and Tutorials.
 

• Edit Key Velocities. Choose this command to tell Finale that you want the editing commands 
(Set To, Add, Scale, Percent Alter, Limit, Alter Feel, and Randomize) to affect the key velocity 
of the selected music. If you select this command while you’re in the MIDI Tool split-window, 
you see the velocities of the notes on the screen represented as a bar graph; see MIDI TOOL 
SPLIT-WINDOW.

After you select this command, a check mark appears beside it in the MIDI Tool Menu.

• Edit Note Durations. Choose this command to tell Finale that you want the editing com-
mands to affect the Start Times and Stop Times of the selected music. If you select this com-
mand while you’re in the MIDI Tool split-window, you see the durations of the notes on the 
screen represented graphically as horizontal lines—the longer the line, the longer the note; see 
MIDI TOOL SPLIT-WINDOW. After you select this command, a check mark appears beside it in 
the MIDI Tool Menu.

• Edit Continuous Data. When you choose this command, the View Continuous Data dialog 
box appears, in which you can specify which MIDI controller data you want to edit (and view, 
if you’re in the MIDI Tool split-window). Sustain pedal usage, pitch or modulation wheel 
changes, patch changes, and monophonic aftertouch are a few of the options; if you have other 
kinds of controllers, you can identify them by number. After you’ve specified the continuous 
data type you want to edit, you return to the score (or MIDI Tool split-window); you can now 
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use the MIDI Tool Menu commands to affect the specified controller data. (Note that the Alter 
Feel and Randomize commands aren’t available if you’re editing continuous data.) After you 
select this command, a check mark appears beside it in the MIDI Tool Menu.

• Set To. When you choose this command, the Set To dialog box appears, in which you can set 
the values of the specified MIDI data type (velocity, durations, or continuous data) for all 
selected notes to a single value. For example, you could set the key velocities for all selected 
notes to 100 (on the MIDI velocity scale of 0 to 127).

Use this command to create pedaling, after using the Continuous Data command (see below) 
to specify that you want to edit sustain pedal data. Select the point at which you want the sus-
tain pedal to go down by dragging through a small sliver of the graph area. (The “pedal down” 
message will occur at the beginning of the selected [highlighted] region.) Choose Set To, and 
enter 127; when Finale plays back the music, it will push the pedal “down” at the point you 
specified. Repeat the process at the point where you want the pedal released, but choose Set To 
and enter zero. See PEDAL MARKINGS and SET TO DIALOG BOX.

• Scale. When you choose this command, the Scale dialog box appears, in which you can scale 
the values of the specified MIDI data type (velocity, durations, or continuous data) evenly 
from one value to another across the selected region. You could scale the velocities of the 
notes in a selected region, for example, from a low value to a high one; Finale would play the 
notes back with a smooth crescendo. See SMART PLAYBACK PLUG-IN. This command is also 
useful for creating pitch bends.
You can scale the MIDI velocity values either from one specified absolute value to another, or 
from one percentage of the original value to another (from 15% to 50% of the original values, 
for example); see SCALE DIALOG BOX.

• Add. When you choose this command, the Add dialog box appears, in which you can add a 
positive or negative amount to the values of the specified MIDI data type (velocity, durations, 
or continuous data) for all selected notes. You could add a certain amount to the key velocity 
data for every note, for example, or make a pitch bend less “deep.” See ADD DIALOG BOX.

• Percent Alter. When you choose this command, the Percent Alteration dialog box appears, in 
which you can increase or decrease the values of the specified MIDI data type (velocity, dura-
tions, or continuous data) for all selected notes by a percentage of their original values. You 
could make the key velocity for every note twice as high, for example, by specifying an 
increase of 200%. See PERCENT ALTERATION DIALOG BOX.

• Limit. When you choose this command, the Limit dialog box appears, in which you can limit 
the values of the specified MIDI data type (velocity, durations, or continuous data) for all 
selected notes to a certain minimum and maximum value. Any notes with values above the 
maximum you specify will be clipped back to that maximum value; any notes with values 
below the minimum will be boosted to that minimum value. For example, if you discover that 
you can’t hear any of the guitar notes in your score when the synthesizer keys are “struck” 
(during playback) with a velocity under 50, you could “limit” the entire guitar staff to a mini-
mum velocity value of 50. See LIMIT DIALOG BOX.

• Alter Feel. Like the Add or Percent Alter commands, the Alter Feel command displays a dia-
log box that lets you add a positive or negative number to the velocities or durations of every 
note in the selected region. However, in the Alter Feel dialog box, you can target individual 
beats in each measure to receive the alterations. For example, if you’ve selected Key Veloci-
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ties, you can specify that the downbeat of each measure in the selected region should be 
played back with 50% more volume, while the other beats in the measure are unaffected. In 
fact, you can specify a different value for Downbeats, Other beats, and Backbeats; see ALTER 
FEEL DIALOG BOX. (The Alter Feel command isn’t available if you’ve selected Continuous 
Data from the MIDI Tool Menu.)

• Randomize. When you choose this command, the Randomize dialog box appears, in which 
you can specify an amount by which you want to randomly alter the velocity or duration val-
ues for all selected notes. This can be a useful option if you want to give your playback a more 
imperfect, “human” feeling. Type a fairly small number into the box—to randomize key 
velocities, for example, you might enter a number between 10 and 20 (unless you really want 
some unpredictable, madcap accents). See RANDOMIZE DIALOG BOX. (The Randomize com-
mand isn’t available if you’ve selected Continuous Data from the MIDI Tool Menu.)

• Edit MIDI Note. When you choose this command, the Edit MIDI Note dialog box appears, in 
which you can set the start and stop times, and the key velocity of a note in one place. See 
EDIT MIDI NOTE DIALOG BOX.

• Play. This command, available if the MIDI Tool split-window is open, plays the displayed 
music immediately using the captured MIDI data.

• Show Selected Notes. This command, only available if the MIDI Tool split-window is open, 
tells Finale to draw lines in the graph area for only notes whose handles are selected. If you’re 
working with a “notey” score, for example, or if you’re trying to work with an inner melody in 
a chordal passage, choose this option to hide the graph lines for the notes that aren’t essential 
to what you’re doing. (Because MIDI controller data isn’t associated with individual notes, 
this command is dimmed if Continuous Data is selected in the MIDI Tool Menu.)

Copy MIDI Data dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p, and select a region 

of measures. Drag the selected region so that it’s superimposed on the first target (destination) 
measure, or ctrl-shift-click the target measure (as long as the target measures aren’t directly above 
or below the selected measures).

What it does
When you copy MIDI data, Finale offers you the chance to create multiple copies, placed one 
after another. For example, if you want the same accents (key velocity information) from one-
measure to extend for an eight measure passage (repeat seven more times), you need only enter it 
once (in the first measure); then you can use the MIDI Tool to copy it into the second measure 
(make sure that Key Velocities is selected in the MIDI Tool Menu). The Copy MIDI Data dialog 
box appears, asking how many times you want it copied. If you enter 7 and click OK, Finale will 
copy the selected measure into the next seven measures.
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• How Many Times?. In this text box, enter the number of times you want the selected MIDI 
data copied. If you enter a number higher than 1, Finale will place the additional copies after 
the first copy, on the same set of staves.

• OK • Cancel. Click OK (or press enter) to proceed with, or Cancel to abort, the copying pro-
cess. You return to the score.

Listen dialog box

How to get there
Click any Listen button in any MIDI-related dialog box.

What it does
Instead of making you type in MIDI codes, Finale often displays a Listen button so that you can 
play the MIDI note, pedal, or chord you’re supposed to input. When you click Listen, this alert 
box appears. It disappears either when you play a note, pedal, or controller on your MIDI instru-
ment, or when you click Cancel.

• Cancel. If your MIDI system isn’t working, or if you change your mind, click Cancel to return 
to the previous dialog box.
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View Continuous Data dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p and select a region 

of measures in a staff. Double-click the selected region to enter the MIDI Tool split-window, if 
you want. Choose Continuous Data from the MIDI Tool Menu.

What it does
The MIDI Tool allows you to edit the values of any MIDI continuous data (controllers, wheels, 
and so on). In this dialog box, you specify the controller whose data you want to edit.

• Controller ___. [Controller drop-down list] In this text box you can specify a controller by 
entering its number, or use the drop-down list to see a list of standard controller messages with 
a brief description. Here are some common controllers and their numbers:

You’ll find other examples in the APPENDIX–MORE ON MIDI.
• Patch Changes • Channel Pressure • Pitch Wheel. Select the data you want to view and 

edit. When you click OK, you’ll be able to edit the specified data type.

Controller 
number

Controller
Controller 

number
Controller

1 Modulation wheel or lever 64 Sustain pedal

2 Breath Controller 65 Portamento

4 Foot Controller 66 Sostenuto

7 Main volume 67 Soft Pedal

10 Pan
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For instructions on editing these data types, see MIDI TOOL SPLIT-WINDOW.

• Listen. If you’re not sure of the number or name of the MIDI controller type whose data you 
want to edit, click Listen. Finale goes into listening mode until you “play” the controller; it 
then enters the correct controller number in the text box.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, your controller selec-
tions. You return to the MIDI Tool split-window.

Set To dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some mea-

sures. Specify the MIDI data type you want to edit by choosing Key Velocities, Note Durations, or 
Continuous Data from the MIDI Tool Menu. If you’re in the MIDI Tool split-window, select the 
region you want to affect by dragging through the “graph” display area or by selecting the handles 
of individual notes whose MIDI data you want to edit. Choose Set To from the MIDI Tool Menu.

What it does
This dialog box’s wording changes to reflect your MIDI data type selection (key velocities, note 
durations, or continuous data). Its function is to allow you to set the values of the selected MIDI 
data type to a specified value. For example, if you’ve selected Key Velocities, you can specify that 
all notes in the selected region should be played back with the same volume by setting their veloc-
ity values to a single MIDI velocity value. (MIDI velocity is measured on a scale of zero, silent, to 
127, very loud.)
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• Set Key Velocities to ____ [Key Velocities] • Set Continuous Data to ____ [Continuous Data]. In 
the text box, enter the value to which you want to set the specified MIDI data type within the 
selected region. 

If you’ve selected Key Velocities, the numbers in these text boxes represent MIDI velocity val-
ues (which range from 0 to 127); Finale will set all notes in the selected region to the key 
velocity value you enter in the text box. 

If you’ve selected Continuous Data, the number you enter in the text box pertains to the con-
troller you’ve specified (on a scale from 0 to 127). For example, the sustain pedal (controller 
64) only has two possible values: 127 (pedal down) and zero (pedal up). Therefore, to insert a 
“pedal down” message, click in the “graph area” of the MIDI Tool split-window at the loca-
tion where you want it to occur and drag to the right. (It doesn’t matter whether you select a 
large region by dragging or only a tiny vertical sliver—all Finale needs to know is where the 
beginning of the selection falls, because that’s where it will insert the “pedal down” message.) 
Choose Set To from the MIDI Tool Menu, and enter the 127 in the text box. (Be sure to use the 
Set To command again later in the passage to set the sustain pedal’s value to zero, or Finale 
will play back your piece as though the sustain pedal was never released.)

• Start Time • Stop Time. These text boxes only appear if you’ve selected Note Durations; the 
Set To values you specify are Start Times or Stop Times. The Start Time is the difference 
between the notated, or quantized, attack of a note and the moment you actually struck the 
note in your performance. The Stop Time is the difference between the notated release of the 
note and the moment you actually released the note (see Installation & Tutorials or START 
AND STOP TIMES for full discussions of these terms).

In this case, then, you’re setting the Start and Stop Times of all notes in the selected region to 
a certain number of EDUs (1024 per quarter note). If you enter zero in both text boxes (and 
select both checkboxes), Finale will adjust the attacks and releases of the notes in the selected 
region so that they’re perfectly “quantized” with their notated values; when you play them 
back, they’ll sound rhythmically perfect. If you click Stop Times and enter 512 in the text box, 
for example, Finale will sustain every note in the selected region one eighth note’s time 
beyond its notated value.

• Patch • Bank Select 0 • Bank Select 32 • Program Change • General MIDI. To enter bank 
and program change data from the MIDI Tool, follow the procedure for entering simple patch 
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changes, then enter the program change and bank select values into the Set Patch To dialog 
box that appears. You can also select the instrument you want from the General MIDI drop 
down list to automatically set up the Bank Selects and Program Change required. See 
PATCHES.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

Scale dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a region of 

measures. Specify the MIDI data type you want to edit by choosing Key Velocities, Note Dura-
tions, or Continuous Data from the MIDI Tool Menu. If you’re in the MIDI Tool split-window, 
select the region you want to affect by dragging through the “graph” display area or by selecting 
the handles of individual notes whose MIDI data you want to edit. Choose Scale from the MIDI 
Tool Menu.

What it does
This dialog box’s wording changes to reflect your MIDI data type selection (key velocities, note 
durations, or continuous data). Its function is to let you scale the values of the specified MIDI data 
type gradually from one value to another. For example, if you’ve selected Key Velocities, you can 
create a smooth crescendo by scaling the key velocities of the notes in the region from 10 to 90. 
(MIDI velocity is measured on a scale from zero, which is very quiet, to 127, which is very loud.) 
See also SMART PLAYBACK PLUG-IN.
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• Start Times • Stop Times. These two radio buttons only appear if you’ve selected Note Dura-
tions as the MIDI data type you want to edit. They let you specify which MIDI data type you 
want to scale from one value to another—either the Start Time (the difference between the 
notated attack of a note and the time you actually played it when recording in Transcription 
Mode) or the Stop Time (the difference between the notated release of a note and the time you 
actually released it). 

• from ___ to ___. In these text boxes, enter the beginning and ending values of the gradual 
change you want Finale to effect over the selected region (for the selected MIDI data type). 
If you’ve selected Key Velocities, the numbers in these text boxes represent either MIDI veloc-
ity values or percentages of the existing key velocity values, depending on whether you’ve 
selected Absolute or Percent of Original (see below). (MIDI key velocity values range from 0 
[very quiet] to 127 [very loud]). If you enter a larger value in the first text box, the result will 
be a decrescendo; if you enter a larger value in the second box, the result will be a crescendo.
If you’ve selected Note Durations, the values you’re scaling are Start Times or Stop Times. 
The Start Time is the difference between the notated, or quantized, attack of a note and the 
moment you actually struck the note in your performance. The Stop Time is the difference 
between the notated release of the note and the moment you actually released the note (see 
Installations and Tutorials or START AND STOP TIMES for full discussions of these terms). The 
Start and Stop Times are measured in EDUs (1024 per quarter note).
Therefore, by scaling the Start Times from, say, zero to –512 over a specific range, the notes 
will sound as though they’re being struck more and more before the beat, until they’re an 
entire eighth note (512 EDUs) early. If you scale the Stop Times from, say, 1024 to zero, the 
notes will sound as though they’re being sustained for shorter and shorter amounts of time 
beyond their notated values.
Finally, if you’ve selected Continuous Data, the numbers you enter in the From and To boxes 
pertain to the controller you’ve specified (on a scale from -8192 to 8192). For example, you 
could create a smooth pitch bend by scaling the pitch wheel data for a selected region from 0 
(the pitch wheel’s at rest value) to 8192. (Be sure you then scale it back down to 0 later in the 
piece, or your synthesizer will think that its pitch wheel is “stuck,” and all notes your synthe-
sizer plays will be transposed.)

• Absolute • Percent of Original. When Finale scales the selected MIDI data from the value in 
one text box to the value in the other, it needs to know whether these specified values are the 
actual absolute values (from 0 to 127 for Key Velocities, for example) or percentages of the 
existing values. For example, if you click Absolute when creating a crescendo, the crescendo 
will be perfect; any subtle variations in key velocity among the notes of the selected passage 
(recorded from your original performance) will be lost. If you clicked Percent of Original, 
however, you could scale key velocities from, say, 50% to 200% of all notes’ current veloci-
ties, thus preserving individual dynamic fluctuations within the passage while still creating an 
effective crescendo.
(These options aren’t available when you’re editing Note Durations.)

• in Increments of ___. This text box only appears if you’re editing Continuous Data, and it has 
no effect unless you’ve selected Absolute (see above). It lets you specify the increments by 
which you want Finale to scale the specified data type. For example, if you scale the pitch 
wheel from -8192 to 0 in increments of one, the pitch bend will be extremely smooth. But 
such a pitch bend will also take Finale a long time to calculate, and the storage of such large 
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amounts of data will increase the amount of disk space consumed by your document. If you 
create the same pitch bend in increments of five or ten, however, Finale has far fewer calcula-
tions to make, but the pitch bend may sound less smooth.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

Add dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some mea-

sures. (If you’re editing a one-staff region, double-click to enter the MIDI Tool split-window.) 
Specify the MIDI data type you want to edit by choosing Key Velocities, Note Durations, or Con-
tinuous Data from the MIDI Tool Menu. If you’re in the MIDI Tool split-window, select the region 
you want to affect by dragging through the “graph” display area or by selecting the handles of 
individual notes whose MIDI data you want to edit. Choose Add from the MIDI Tool Menu.

What it does
The Add dialog box’s contents change to reflect your MIDI data type selection (key velocities, 
note durations, or MIDI continuous data such as controllers and wheels). Its function is to add a 
fixed amount to (or subtract a fixed amount from) the key velocity, duration, or controller value of 
every note in the selected region. Because it adds an absolute amount to every selected note, the 
Add command preserves the relative proportions of the existing values.

For example, if you’ve selected Key Velocities, you can specify that each note in a selected region 
should be played back with slightly more volume by adding, for example, 20 MIDI velocity units. 
(MIDI velocity is measured on a scale from zero, which is silent, to 127, which is very loud.)
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• Add ___. In this text box, enter the value you want added to the selected MIDI data values 
(key velocities, note durations, or MIDI controller settings) of all selected notes. Note that in 
any of the examples below, this value can be a positive or negative number.

If you selected Key Velocities from the MIDI Tool Menu, the number in this text box repre-
sents the number of MIDI velocity units you want added to every note in the selected region; 
MIDI key velocity is measured on a scale from zero, which is silent, to 127, which is very 
loud.
If you selected Note Durations, the number in this text box represents the number of EDUs, of 
which there are 1024 per quarter note, you want added to the Start and Stop Times of the 
selected notes. (See START AND STOP TIMES for a discussion of Start and Stop Times). You 
specify whether you want this value added to Start Times, Stop Times, or both by clicking one 
or both of the checkboxes (see “Start Times/Stop Times,” below).
If you select Continuous Data from the MIDI Tool Menu, a dialog box appears in which you 
can specify the MIDI controller you want to edit—pedaling, patch changes, pitch wheel, and 
so on. In this case, the number in the Add text box specifies a value you want added to the 
selected controller’s value for all the selected music. The Add command isn’t relevant if 
you’ve specified a non-continuous controller such as the sustain pedal or a patch change; it 
may be useful, however, if you want to increase the degree of pitch bend or monophonic after-
touch by a uniform amount for every note in the selected region.

• Start Times • Stop Times. These two checkboxes only appear if you’ve selected Note Dura-
tions from the MIDI Tool Menu. They let you specify which MIDI data type you want to 
edit—either the Start Time (the difference between the notated attack of a note and the time 
you actually played it when recording in Transcription Mode) or the Stop Time (the difference 
between the notated release of a note and the time you actually released it). If you select both 
checkboxes, the effect of the Add command is to shift the playback of the entire note forward 
or backward in time.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

Percent Alteration dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a region of 

measures. (If you’re editing only a single staff, double-click the highlighted area to enter the MIDI 
Tool split-window.) Specify the MIDI data type you want to edit by choosing Key Velocities, Note 
Durations, or Continuous Data from the MIDI Tool Menu. If you’re in the MIDI Tool split-win-
dow, select the region you want to affect by dragging through the “graph” display area or by 
selecting the handles of individual notes whose MIDI data you want to edit. Choose Percent Alter 
from the MIDI Tool Menu.

What it does
This dialog box’s contents change to reflect your MIDI data type selection (key velocities, note 
durations, or continuous data). Its function is to change the key velocity, duration, or continuous 
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data value of every note in the selected region by a percentage of its current value. Because it 
changes the data of every selected note by a percentage, the Percent Alter command preserves the 
relative proportions of the existing values.
For example, if you’ve selected Key Velocities, you can specify that each note in a selected region 
should be played back with half its volume by entering 50 (%) in the text box.

• ___ percent of current value. In this text box, enter the percentage by which you want the 
selected MIDI data (key velocities, note durations, or MIDI controller settings) changed for 
the selected notes. This value can be any number above zero—you can enter 300%, for exam-
ple, to make a particular value three times its current value. (The absolute value of key veloci-
ties and MIDI controllers can’t exceed 127, however.)

If you selected Key Velocities from the MIDI Tool Menu, the number in this text box repre-
sents a percentage of each note’s current MIDI velocity level; MIDI key velocity is measured 
on a scale from zero, which is silent, to 127, which is very loud.

If you selected Note Durations, the number in this text box represents the amount by which 
you want to shorten or lengthen the playback durations of all selected notes (regardless of 
their notated durations). Note that this is the only MIDI Tool command that directly modifies 
the durations of existing notes (the other commands modify the notes’ durations indirectly, by 
manipulating their Start and Stop Times). For example, if you want a region of eighth notes 
and quarter notes to play back staccato, enter 50 (%) in this box; the notes will be sustained for 
only half their original durations.

If you select Continuous Data from the MIDI Tool Menu, a dialog box appears in which you 
can specify the MIDI controller or wheel data you want to edit—pedaling, patch changes, 
pitch wheel, and so on. In this case, the number in the Percent Alteration text box specifies a 
percentage by which you want that controller’s values multiplied for all the selected music. 
The Percent Alter command isn’t relevant if you’ve specified a non-continuous controller such 
as the sustain pedal or a patch change; it may be useful, however, if you want to increase the 
degree of pitch bend or monophonic aftertouch by a uniform amount for every note in the 
selected region.
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• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

Limit dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some mea-

sures. Specify the MIDI data type you want to edit by choosing Key Velocities, Note Durations, or 
Continuous Data from the MIDI Tool Menu. If you’re in the MIDI Tool split-window, select the 
region you want to affect by dragging through the “graph” display area or by selecting the handles 
of individual notes whose MIDI data you want to edit. Choose Limit from the MIDI Tool Menu.

What it does
This dialog box’s wording changes to reflect your MIDI data type selection (key velocities, note 
durations, or continuous MIDI data). Its function is to allow you to limit the values of the speci-
fied MIDI data type to within a specified range of values. For example, if you’ve selected Key 
Velocities, you can specify that no note in the selected region should be played back with volume 

above an F dynamic level by limiting the notes in the region to a maximum MIDI velocity value 
of, say, 90. (MIDI velocity is measured on a scale of zero, which is silent, to 127, which is very 
loud.)
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• Minimum of ____ • Maximum of ____. In these text boxes, enter the minimum and maxi-
mum values permissible for the specified MIDI data type within the selected region. Any 
existing data values below the minimum value you specify will be boosted to that minimum 
value; any existing values above the maximum value will be clipped down to that maximum 
value.

If you’ve selected Key Velocities, the numbers in these text boxes represent MIDI velocity val-
ues (which range from 0 to 127); using the maximum and minimum text boxes, you can con-
fine the playback of all notes in the selected region to a certain dynamic range.

If you’ve selected Note Durations, the maximum and minimum values you specify are Start 
and Stop Times. The Start Time is the difference between the notated, or quantized, starting 
point of a note and the moment you actually struck the note in your performance. The Stop 
Time is the difference between the notated release of the note and the moment you actually 
released the note (see Installation & Tutorials, or START AND STOP TIMES, for full discussions 
of these terms).
In this case, then, the values you’re limiting to a maximum or minimum value are the Start and 
Stop Times, measured in EDUs (1024 per quarter note). If you enter zero in both text boxes, 
Finale will adjust the attacks and releases of the notes in the selected region so that they’re 
perfectly “quantized” with their notated values; when you play them back, they’ll sound 
rhythmically perfect. If you enter positive or negative numbers in either text box, you limit 
both Start and Stop Times to the specified number of EDUs from the notated durations.
Finally, if you’ve selected Continuous Data, the numbers you enter in the maximum and mini-
mum boxes pertain to the controller you’ve specified (on a scale from 0 to 127). For exam-
ple—although it doesn’t make much musical sense—you could limit the patch numbers in the 
selected region to within a certain range. More practically, you could limit the amount of 
monophonic aftertouch within a selected region to a certain maximum value—so that you’ll never 
hear more than a certain amount of vibrato on any note, for example.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

Alter Feel dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some mea-

sures. (If you’re editing a one-staff region, double-click to enter the MIDI Tool split-window.) 
Specify the MIDI data type you want to edit by choosing Key Velocities or Note Durations from 
the MIDI Tool Menu. If you’re in the MIDI Tool split-window, select the region you want to affect 
by dragging through the “graph” display area or by selecting the handles of individual notes 
whose MIDI data you want to edit. Choose Alter Feel from the MIDI Tool Menu.

What it does
The Alter Feel dialog box’s contents change to reflect your MIDI data type selection (key veloci-
ties or note durations; the Alter Feel command isn’t available for Continuous Data). Like the Add 
or Percent Alter commands, the Alter Feel command lets you add a positive or negative number to 
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the velocities or durations of every note in the selected region. However, in the Alter Feel dialog 
box, you can target individual beats in each measure to receive the alterations. 

For example, if you’ve selected Key Velocities, you can specify that the downbeat of each mea-
sure in the selected region should be played back with 50% more volume, while the other beats in 
the measure are unaffected.

When you read the following descriptions of the three text boxes, keep in mind that the number in 
each text box produces a different effect depending on whether the Absolute or Percent of Origi-
nal button is selected (see below). For example, to double the key velocity of all downbeats (to 
make them twice as loud), click Percent of Original and enter 200 in the Downbeats By text box. 
But to add an equal amount of velocity to all downbeats—thus preserving their relative velocity 
values—click Absolute and enter a MIDI key velocity value in the Downbeats By text box.

• Downbeats by. A downbeat is defined as the first beat in the measure. By entering a value in 
this text box, you can increase or decrease the velocity (or the Start Time) of only the down-
beats of the measures in the selected region. 

• Other Beats by. Other Beats means every beat in every measure except a downbeat or a back-
beat. The beat is determined by the durational value of the denominator in the Time Signature 

dialog box; for example, Other Beats of a  meter would be the second and third quarter note 

of each measure if you represented the meter as q q q in the Time Signature dialog box. How-

ever, if you represented the  meter as a h. in the Time Signature dialog box (a waltz “in 

one,” for example), there would be no “other beats” in each measure; see TIME SIGNATURE 
DIALOG BOX.

3

4
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3

4
---
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By entering a value in this text box, you can increase or decrease the velocity (or the Start and 
Stop Times) of only the other beats of the measures in the selected region. (If you’ve selected 
Note Durations from the MIDI Tool Menu, you’re editing both the Start Time of each “other 
beat” and the Stop Time of the previous note.)

• Backbeats by. In Finale, a backbeat (sometimes called an offbeat) is the second half of the 

beat (in duple meters); thus the second eighth note of every beat in  or  time—or the second 

quarter note of every beat in  time—is the backbeat. In triple meters, the second and third 

thirds of the beat are the backbeats. In both cases, “beat” is determined by the durational value 

of the denominator in the Time Signature dialog box. The backbeats of a  meter could either 

be the second eighth note of each beat (if you represented the meter with three quarter notes in 
the Time Signature dialog box) or the second and third quarter notes of the measure (if you 
represented the meter as a dotted half note in the Time Signature dialog box); see TIME SIGNA-

TURE DIALOG BOX.

The number in this text box represents the amount by which you want to modify every back-
beat in the selected region. (If you’ve selected Note Durations from the MIDI Tool Menu, 
you’re editing both the Start Time of each backbeat and the Stop Time of the previous note.)

One of the best uses for this option is to slightly delay the playback of every backbeat (by 
choosing Note Durations from the MIDI Tool Menu and then choosing the Alter Feel com-
mand). For example, by entering 171 into the Backbeats By text box, you create a true triplet 
swing feel. (See SWING)

• Absolute • Percent of Original. If Absolute is selected, the number in the text box represents 
MIDI key velocity units (where zero is silent and 127 is very loud) or EDUs (1024 per quarter 
note), depending on whether you’re editing key velocities or note durations. If Percent of 
Original is selected, the number in the text box represents a percentage of the original key 
velocity or Start and Stop Time values by which you want these data changed.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

Randomize dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a region of 

measures. Specify the MIDI data type you want to edit by choosing Key Velocities or Note Dura-
tions from the MIDI Tool Menu. If you’re in the MIDI Tool split-window, select the region you 
want to affect by dragging through the “graph” display area or by selecting the handles of individ-
ual notes whose MIDI data you want to edit. Choose Randomize from the MIDI Tool Menu.

What it does
In this dialog box, you can direct Finale to alter the velocity or duration values for all selected 
notes at random. This can be a useful option if you want to give your playback a more imperfect, 

2

4
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4
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4
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“human” feeling; or, by very slightly randomizing the Start Times of the notes in your piece, you 
can alleviate MIDI playback problems caused by too much note information being sent at the 
same instant to your MIDI instrument. (The Randomize command isn’t available if you’ve 
selected Continuous Data from the MIDI Tool Menu.)

The wording of the dialog box changes to reflect your MIDI data type selection (key velocities or 
note durations).

 

• Randomize the Key Velocities but Limit the Change to ___. In this text box, enter the max-
imum amount by which you want Finale to randomly vary the key velocity values of the notes 
in the selected region. The number in this text box represents MIDI velocity units, which are 
on a scale from zero, which is silent, to 127, which is very loud. You’ll probably find that a 
number between 10 and 20 produces satisfactory results (a more human “feel”) without intro-
ducing obvious accents.

• Start Times limited to ___ • Stop Times limited to ___. The numbers in these text boxes rep-
resent the amount by which you want to randomly vary the attack or release points of all 
selected notes’ playback (regardless of their notated durations). You’re specifying the maxi-
mum number of EDUs, of which there are 1024 per quarter note, you want added to (or sub-
tracted from) the Start or Stop Times of the selected notes (see START AND STOP TIMES for a 
discussion of Start and Stop Times).

You might enter an EDU value of 1⁄16 (or less) of the predominant rhythmic values in the 
music, unless you want to produce unpredictable, strange rhythmic effects. To subtly soften 
the rhythmic precision of an eighth note (512 EDUs) passage, for example, you might type 32 
into the Start and Stop Times boxes.

• OK • Cancel. Click OK (or press enter) to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).
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Edit MIDI Note dialog box
How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a note han-

dle in the MIDI Tool split- window and choose Edit MIDI Note from the MIDI Tool Menu or dou-
ble-click a note handle in the MIDI Tool split-window.

What it does
This dialog box simply provides a convenient way to edit the Start and Stop Times and Key Veloc-
ity of a note in one place.

• MIDI Note Number. This text tells you the MIDI Note Number of the selected note.

• Start Time • Stop Time. Enter the Start Time and Stop Time for the selected note. See  START 
AND STOP TIMES for more information on how to use these options.

• Velocity. Enter the Key Velocity for the selected note. See KEY VELOCITY for more informa-
tion.

• OK • Cancel. Click OK (or press enter to confirm, or Cancel to discard, the MIDI data 
changes you’ve specified. You return to the MIDI Tool split-window (or the score).

MIDI Tool split-window

How to get there

From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Click to select one 

measure, shift-click to select additional measures, drag-enclose to select several on-screen mea-
sures, or click to the left of the staff to select the entire staff. Double-click the selected region.

What it does
The MIDI Tool split-window provides a graphic display of the three kinds of captured MIDI data 
you can edit: key velocities, note durations (Start and Stop Times), and continuous data, which 
includes controllers (use of the pedals, patch changes, aftertouch) and wheels (pitch wheel, and so 
on). Because the window displays not only a graphic representation of these values for each note 
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but also the notes themselves, you can get an immediate picture of the relationship between the 
two. 

Furthermore, the MIDI Tool split-window offers you an option not available when you use the 
MIDI Tool commands without opening this window—you can edit specific notes, even if they’re 
nonadjacent or buried within chords. (For a full discussion of the kinds of data you can edit with 
the MIDI Tool and an explanation of the commands available, see MIDI TOOL MENU. For a com-
plete tutorial in the use of the MIDI Tool, see Installations & Tutorials.)

When you edit MIDI data in the MIDI Tool split-window, the changes you make apply to the 
selected layer (as indicated by the Layer push buttons on the bottom of the document window) 
and only to the top staff you are viewing. To edit a different staff, use the vertical scroll bar to 
move up and down through the staves. Use the horizontal scroll bars to move through your score 
as you normally would.

There are several ways to select specific notes in the split-window. To select one, click its handle; 
to select additional notes, shift-click their handles. You can also drag-enclose several handles to 
select them, or shift–drag-enclose to select additional groups. You can also select all notes within 
a certain region by dragging through the graph area (above the displayed notes); Finale responds 
by highlighting the handles of all notes within the region you select. (To select an additional 
region of notes in this way, shift-drag through the graph area.) To “deselect” a selected handle, 
shift-click it.
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• Key Velocities. Choose this item from the MIDI Tool menu to tell Finale that you want to edit 

the key velocities of the notes displayed in the window (a graph of how hard each note was 
struck). The display becomes a graph; thin vertical lines represent the relative velocities of the 
notes displayed at the bottom of the window, and a “velocity ruler”— with notches from zero 
(silence) to 127 (very loud)—appears along the left edge.

If you’ve entered music with the Simple or Speedy Entry tools, the velocity of every note is 
64. (64 is Finale’s default note velocity setting, which you can change by choosing Playback 
Controls from the Window Menu, clicking the expand arrow, and entering a new value in the 
Base Key Velocity text box.) If you’ve captured the key velocity (performance) data from a 
real-time HyperScribe performance, however, you’ll see those varying velocities displayed in 
this graph notation.
To edit the velocity of a particular note, double-click its handle. The Set To dialog box 
appears, in which you can enter a new velocity value. To edit the velocities of several notes, 
select them with any of the methods described above, then choose the appropriate command 
from the MIDI Tool Menu (see MIDI TOOL MENU). To restore selected notes to their default 
velocity values, press backspace or use the Mass Mover Tool to erase Performance Data.
(Technical note: Finale stores the captured velocity values as the difference between the actual 
velocity with which you struck the notes and the default velocity, as determined by the Base 
Key Velocity text box in the Playback Controls. If you increase or decrease this Base Key 
Velocity value, therefore, you instantly increase or decrease the playback velocity of every 
note in the piece, even though their velocity values remain the same in proportion to one 
another.)

• Note Durations. Choose this item from the MIDI Tool menu to tell Finale that you want to 

edit the Start and Stop Times of the notes—the slight deviations from the beat that create 
swing feel, rolled chords, and so on—displayed in the window. The display becomes a graph; 
thin horizontal lines represent the relative note durations of the notes displayed at the bottom 
of the window, and a piano keyboard appears at the left edge to help you identify their pitches. 
Drag this keyboard up or down if you want to view higher or lower notes.
If you’ve entered music with the Simple or Speedy Entry tools, the Start and Stop Times of 
every note are zero, because the definitions of Start and Stop Times are the differences 
between the notated attack and release points of the notes and the actual (performed) attack 
and release points. (See START AND STOP TIMES for a more complete discussion.) The graph 
of a note whose Start Time is zero is perfectly flush with the vertical gridline representing its 
notated attack point, and that of a note whose Stop Time is zero stops neatly at the gridline 
representing its notated release point, as shown:
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The notes displayed in the MIDI Tool split-window were entered with one of Finale’s step-time 
entry tools. Therefore, each note’s Start Time and Stop Time is zero, as you can see from the fact 
that each horizontal line (representing a note’s duration) ends flush with one of the dotted vertical 
lines. (The vertical lines represent the notated, or quantized, attack and release points of the notes.)

If you’ve captured the Start and Stop Time (performance) data from a real-time HyperScribe 
performance, however, you’ll see horizontal lines that don’t begin and end nearly so precisely 
at the vertical gridlines. For example, the graph of a note you held down slightly beyond the 
beginning of the next beat appears to extend just to the right of the vertical gridline (and has a 
positive Stop Time). The graph of a note you struck a fraction of a second early begins just 
before a vertical gridline (and has a negative Start Time).

To edit the Start and Stop Time of a particular note, double-click its handle; the Set To dialog 
box appears, in which you can enter a new value. To edit the Start and Stop Times of several 
notes, select them with any of the methods described above, then choose the appropriate com-
mand from the MIDI Tool Menu (see MIDI TOOL MENU). To set the Start and Stop Times of 
selected notes to zero (so that they play back with “quantized” rhythmic perfection), press 
backspace or use the Mass Mover Tool to clear Continuous Data.

• Continuous Data. Choose this item from the MIDI Tool menu to tell Finale that you want to 

edit the continuous MIDI data—pedals, wheels, patch changes, and other non-note data—for 
the music displayed in the window. The View Continuous Data dialog box appears, allowing 
you to specify the controller data type you want to edit. (Patch Changes, Monophonic After-
touch, and Pitch Wheel are dimmed, because these data have icons of their own in the MIDI 
Tool window [see below].) See VIEW CONTINUOUS DATA DIALOG BOX for descriptions of the 
elements of this dialog box.

When you return to the MIDI Tool split-window, the display becomes a graph; the highlighted 
area represents the specified controller’s value over time. A “value ruler” appears at the left 
edge, with notches from 0 to 127. This scale measures different qualities, depending on the 
controller you’ve selected.
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To edit the controller setting for a particular region, drag through the region so that it’s high-
lighted (black areas become white, and vice versa). Choose the appropriate command from the 
MIDI Tool Menu to add to, subtract from, or otherwise change the controller’s setting during 
the selected region (see MIDI TOOL MENU for a list of the available commands). To set the 
controller to its default value or “at rest” position in the selected region, press backspace or 
use the Mass Mover Tool to clear Continuous Data.

(Technical note: Continuous data is independent of the notes themselves. Therefore, no han-
dles appear on the notes in the MIDI Tool split-window when you’re editing continuous data; 
you must select a region by dragging through the “graph” area rather than by selecting note 
handles. Note, too, that continuous data is displayed as a continuous horizontal “area graph,” 
even if the controller is an event-oriented one, such as a patch change or usage of the pedal. 
See PATCHES and PEDAL MARKINGS for a more complete discussion.)

• Patch Change. Choose this item from the MIDI Tool menu to tell Finale that you want to add 

or remove patch changes in the music displayed in the window.

When you return to the MIDI Tool split-window, the display becomes a graph; Finale tells you 
which patch has been set (in each region) by the height of the highlighted area. A “value 
ruler”—with notches that indicate patch numbers 1 to 128—helps you identify the patch that’s 
selected for each region, as shown in the figure below.

When you’re editing patch changes in the MIDI Tool split-window, the black bars indicate the cur-
rent patch at each patch change.
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To insert a patch change, click in the “graph area” at the location where you want it to occur, 
and drag to the right. It doesn’t matter whether you select a large region by dragging or only a 
tiny vertical sliver—all Finale needs to know is where the beginning of the selection falls, 
because that’s where it will insert the patch change. Choose Set To from the MIDI Tool Menu, 
and enter the patch number you want to change to. (You can also use the other commands 
from the MIDI Tool Menu to change the patch numbers in a selected region, although most of 
these other commands [Scale, Limit, and so on] have little musical relevance to patch num-
bers.) To remove patch changes from a selected region, press backspace or use the Mass 
Mover Tool to clear Continuous Data.

If a bank change is part of a patch setting, Finale displays a “B” in the MIDI Tool split–win-
dow within the graphic display of the patch change. No letter appears above the graph if a sim-
ple patch change was used.

• Channel Pressure. Choose this item from the MIDI Tool menu to tell Finale that you want 

edit channel pressure data (monophonic aftertouch—the pressure you apply to a key while it’s 
being pressed down) in the music displayed in the window.

When you return to the MIDI Tool split-window, the display becomes a graph; the highlighted 
area represents the aftertouch value over time. A “value ruler”—with notches from zero (no 
aftertouch) to 127 (maximum aftertouch)—appears at the left edge.

To edit the channel pressure value for a particular region, drag through the region so that it’s 
highlighted (black areas become white, and vice versa). Choose the appropriate command 
from the MIDI Tool Menu to add, subtract, or otherwise change the aftertouch value during 
the selected region (see MIDI TOOL MENU for a list of the available commands). To set the 
aftertouch values to zero for the entire selected region, press backspace or use the Mass Mover 
Tool to clear Continuous Data.

• Pitch Wheel. Choose this item from the MIDI Tool menu to tell Finale that you want to edit 

pitch wheel data for the music displayed in the window.

When you return to the MIDI Tool split-window, the display becomes a graph; the highlighted 
area represents the position of the pitch wheel over time. A “value ruler” appears at the left 
edge with notches from -8191 (pitch wheel all the way down) to 8192 (pitch wheel all the way 
up). Bear in mind that the pitch wheel’s value is 0 when it’s at rest (neither up nor down).

To edit the pitch wheel setting for a particular region, drag through the region so that it’s high-
lighted (black areas become white, and vice versa). Choose the appropriate command from the 
MIDI Tool Menu to add to, subtract from, or otherwise change the pitch wheel setting during 
the selected region (see MIDI TOOL MENU for a list of the available commands). You may find 
the Scale command to be the most useful for creating pitch bends, because it creates smooth 
gradations from one pitch wheel setting to another.

Be sure to use one of the MIDI Tool Menu commands again later in the music to return the 
pitch wheel to its “at rest” position, however, or your synthesizer will believe that the pitch 
wheel is “stuck” in its transposed position for the remainder of the piece.
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Backbeats
In Finale, a backbeat is the second half of the beat (in duple meters); thus the second eighth note 

of every beat in  or  time (or the second quarter note in  time) is the backbeat. In triple meters, 

the second and third thirds of the beat are the backbeats. In both cases, “beat” is determined by the 

durational value of the denominator in the Time Signature dialog box. The backbeats of a  meter 

could either be the second eighth note of each beat (if you represented the meter with three quarter 
notes in the Time Signature dialog box) or the second and third quarter notes of the measure (if 
you represented the meter as a dotted half note in the Time Signature dialog box). See TIME SIG-

NATURES for more information on defining meters.

You can use the MIDI Tool to affect only the backbeats of a piece. You might, for example, boost 
the velocity of the backbeats to give the music a rockier sound. If you’re preparing a Strauss waltz 
for playback, you could delay the attacks of the backbeats for a slightly more Viennese feeling.

A downbeat is the first beat of the measure. A backbeat is the second half of the beat (or, in a triple 
meter, the second and third thirds of the beat). An Other beat is any other beat, where a “beat” is 
defined as the lower half of the time signature (a quarter note in the top example, a half note in the 
next, and a dotted half note in the bottom example).

To alter the key velocity of backbeats

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p and select 

the region to be affected. Click to select one measure, shift-click to select additional mea-
sures, drag-enclose to select several on-screen measures, click to the left of the staff to select 
the entire staff, or choose Select All from the Edit Menu.

If you want to edit only one staff (and the desired region fits on one screen), double-click the 
highlighted region to enter the MIDI Tool split-window.
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• Choose Key Velocities from the MIDI Tool Menu. 

• Choose Alter Feel from the MIDI Tool Menu. The Alter Feel dialog box appears.

• Enter the desired amount of key velocity alteration (a positive or negative number) in the 
Backbeats By box. The range of MIDI key velocity is 0 to 127, so the number you enter here, 
when added to the existing velocity values of the notes, will not exceed 127. (If you prefer, 
you can click the Percent of Original button and type a percentage value into the Backbeats By 
box.)

• Click OK (or press enter). 

To alter the durations of backbeats
See SWING. Or, see Installation & Tutorials. 

To copy or erase MIDI Tool editing
See MIDI—To copy or erase captured (or edited) MIDI data.

Channel Pressure
Channel Pressure is a type of MIDI information, also called monophonic aftertouch, that 
describes how much pressure you apply to a key while it’s being held down. Finale lets you 
record, edit, and play back Channel Pressure information. (Channel Pressure data describes the 
overall pressure level for an entire MIDI channel at any moment. Contrast with Key Pressure data, 
which describes the pressure being applied to each individual key; some MIDI devices respond to 
this kind of data. Finale records and plays back Key Pressure data, but you can’t edit it.)

When you record a performance with the Transcription Mode of HyperScribe, you can specify 
whether or not you want Finale to retain your Channel Pressure data so that you can later hear it 
applied to the playback of your transcription. For a full description of captured MIDI information, 
see Installation & Tutorials.

To retain Channel Pressure data for score playback
• Record a performance in the using the Transcription Mode. See TRANSCRIBING A 

SEQUENCE for instructions.

• Before saving or transcribing the performance, select Save Continuous Data (in the 
lower-left corner of the Transcription Window). If Play Recorded Continuous Data is 
selected in the Playback Options dialog box (accessed from the expanded Playback Controls 
panel), you will hear your Channel Pressure variations when you play back the transcription.

To edit Channel Pressure data

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. 

• Select the region whose playback data you want to edit. Click to select one measure, shift-
click to select additional measures, drag-enclosed to select several on-screen measures, click 
to the left of the staff to select the entire staff, or choose Select All from the Edit Menu.

• Choose Continuous Data from the MIDI Tool Menu. Click Channel Pressure; click OK. 
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If you want to edit only one staff, double-click the highlighted region to enter the MIDI Tool 
split-window. Drag through the display area above the notes whose Channel Pressure you 
want to edit.

• Edit the selected region by choosing the appropriate command from the MIDI Tool 
Menu. Choose Set To to specify a uniform value for the Channel Pressure of all notes in the 
selected region. Choose Scale to create a gradual change in Channel Pressure values over the 
selected region. Choose Add to add a positive or negative amount to all notes in the selected 
region. Choose Percent Alter to change the Channel Pressure values in the selected region by a 
percentage of their original amounts. Choose Limit to specify a maximum or minimum Chan-
nel Pressure value for the notes in the selected region. (See also SET TO DIALOG BOX; SCALE 
DIALOG BOX; ADD DIALOG BOX; PERCENT ALTERATION DIALOG BOX; LIMIT DIALOG BOX.)

To copy or erase controller data
See MIDI—To copy or erase captured (or edited) MIDI data.

Continuous data
Continuous data is MIDI information that’s not related to individual notes. Usually the term refers 
to devices on your MIDI keyboard that modify the notes in some electronic way: volume and sus-
tain pedals (and other MIDI controllers), pitch and modulation wheels, channel pressure (after-
touch), and breath controllers are some examples. You can record any continuous data when you 
use the Transcription Mode of HyperScribe to transcribe your music; furthermore, using the MIDI 
Tool, you can graphically edit this data.

This entry describes the general recording, playback, and editing of standard controllers. For 
information on specific controllers, see their separate entries: CHANNEL PRESSURE; PATCHES; 
PEDAL MARKINGS; PITCH WHEEL; and VOLUME.

To specify which continuous data you want to record (MIDI Filter)
Because continuous data consumes memory and disk space, you may opt not to record all types of 
this data when you use the Transcription Mode.
• Before recording a performance with the Transcription Mode, choose Input Filter from 

the Transcription Menu. Finale displays the MIDI Input Filters dialog box. You can directly 
enter the controller numbers you want recorded, if you know them. It’s simpler, however, to 
specify the controllers by playing them.

• Click Listen. Briefly play each controller or wheel you want to record in your upcoming per-
formance. As you tap each pedal or wiggle each wheel, Finale records their continuous data 
numbers in the four text boxes. Be sure to also play a note or two, to tell Finale that it should 
record notes, as well.

Any continuous data types you don’t specify in this dialog box won’t be recorded.

• Click OK (or press enter). Proceed with your recording.

To retain continuous data for score playback
When you record a performance in Transcription Mode, Finale temporarily remembers the contin-
uous data that you generated during the performance. Normally, however, Finale discards this 
information when it transcribes your performance into standard notation.



Continuous data 40-29      

OC

OC

ndex

Index

ext 
hapter

ext 
hapter

revious
hapter

revious
hapter
T

T

I

N
C

N
C

P
C

P
C

If you’ll later want to hear and edit this data, however, make sure you follow these steps before 
transcribing:

• Record a performance in Transcription Mode. See TRANSCRIBING A SEQUENCE.

• Before saving or transcribing the performance, click Save Continuous Data. If Play 
Recorded Continuous Data is selected in the Playback Options dialog box (see PLAYBACK), 
Finale will play back your transcribed performance applying the same controllers and wheels 
you did.

To edit continuous data
If you’ve saved continuous data from a performance in Transcription mode, you can edit it 
directly even when the performance has been transcribed into standard notation.

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. 

• Choose Continuous Data from the MIDI Tool Menu. The View Continuous Data dialog 
box appears, and you can choose the MIDI data you want to edit.

• Specify the continuous data you want to edit. If the continuous data type you want to edit is 
listed in the dialog box, click its button (Sustain Pedal, Modulation Wheel, and so on). If not, 
click the Listen checkbox and play the controller. Finale enters the correct controller number 
in the text box automatically.

• Click OK (or press enter). 

• Select the measures whose continuous data you want to edit. Click to select one measure, 
shift-click to select additional measures, drag-enclose to select several on-screen measures, 
click to the left of the staff to select the entire staff, or choose Select All from the Edit Menu.

If you want to edit only a few measures on a single staff, select them, and then double-click 
the highlighted region to enter the MIDI Tool split-window. Drag through the display area 
above the notes whose continuous data you want to edit.

• Edit the selected region by choosing the appropriate command from the MIDI Tool 
Menu. Choose Set To to specify a uniform value for the controller or wheel setting for all 
notes in the selected region. Choose Scale to create a gradual change in the continuous data 
setting over the selected region. Choose Add to add a positive or negative amount to all the 
controller’s values in the selected region. Choose Percent Alter to change the values in the 
selected region by a percentage of their original amounts. Choose Limit to specify a maximum 
or minimum value for the continuous data in the selected region. (See also SET TO DIALOG 
BOX; SCALE DIALOG BOX; ADD DIALOG BOX; PERCENT ALTERATION DIALOG BOX; or LIMIT 
DIALOG BOX.)

To copy or erase continuous data
See MIDI—To copy or erase captured (or edited) MIDI data.
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Downbeats
You can control both aspects of Finale’s handling of downbeats: graphic and playback. For exam-
ple, you might decide that one or all of the downbeats in your piece occur too close to the begin-
ning of the measure.

If you’re using Finale for playback, you can alter the velocity and durational values for some, or 
all, downbeats by using the MIDI Tool.

To move all downbeats graphically
• From the Options Menu, choose Document Settings, then Music Options. The Music 

Options dialog box appears.

• Enter a new value in the first Music text box (in the Before column). The number you type 
here represents the distance between the measure header (clef, key, meter) and the first note or 
rest in the measure. By increasing the number, you can allow more space before every down-
beat in the piece.

• Click OK. 

To move a single downbeat graphically
See BEAT POSITIONS—To move a beat.

To alter the key velocity of downbeats

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p, and choose 

Key Velocities from the MIDI Tool Menu.
• Select the region to be affected. Drag-enclose to select measures, click to the left of the staff 

to select the entire staff, or choose Select All from the Edit Menu.

• Choose Alter Feel from the MIDI Tool Menu. The Alter Feel dialog box appears.

• Enter the desired amount of key velocity alteration (a positive or negative number) in the 
Downbeats By text box. The range of MIDI key velocity is 0 to 127, so the number you enter 
here, when added to the existing velocity values of the notes, can’t exceed 127. (If you like, 
click Percent of Original, and type a percentage value into the Downbeats By text box.)

To alter the attack points of downbeats

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p, and choose 

Note Durations from the MIDI Tool Menu.
• Select the region you want to affect.

• Choose Alter Feel from the MIDI Tool Menu. The Alter Feel dialog box appears.

• Enter the desired amount of Start/Stop Time alteration (a positive or negative number) 
in the Downbeats By text box. The number you enter into the Downbeats By text box is the 
number of 1024ths of a quarter note by which Finale will shift the Start Time of each down-
beat. In other words, Finale moves the audible location of each downbeat’s attack forward or 
backward in time, depending on the number you enter here. (See Installation & Tutorials for a 
detailed discussion of Start and Stop Times.)
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Key velocity
Key velocity, also called note velocity, is the MIDI data that describes how hard a key was struck. 
A note’s key velocity usually determines its volume, although velocity can be programmed to 
affect other playback elements, depending on your MIDI keyboard. Finale can record the key 
velocity for every single note you play using the HyperScribe Tool. See also AUTO-DYNAMIC 
PLACEMENT PLUG-IN.

There are two ways to affect the key velocity of notes in your score. The quickest method uses the 
MIDI Tool to directly edit note (key) velocities. The other method involves placing into the score 
standard musical markings that have been defined for playback (an accent, a forte mark, and so 
on).

To edit key velocity with the MIDI Tool

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Choose Key 

Velocities from the MIDI Tool Menu, if it’s not already selected.

• Select the region whose playback data you want to affect. Click to select one measure, 
shift-click to select additional measures, drag-enclose to select several on-screen measures, 
click to the left of the staff to select the entire staff, or choose Select All from the Edit Menu.

• If the selected region is only on one staff, double-click the highlighted area. You enter the 
MIDI Tool split-window. At the bottom of the window you see the music on the staff you 
selected. Above each note is a thin vertical line; in essence, these lines are a bar graph of the 
key velocities of the displayed notes. Click the up, down, left, and right arrow buttons to move 
through the score a measure at a time.

While in the MIDI Tool split-window, you have note-by-note editing powers for the displayed 
notes. To select the notes whose velocities you want to edit, drag through the graph area of the 
window, highlighting it; the handles of all displayed notes are selected. You can also click an 
individual note’s handle, or shift-click additional handles, or drag-enclose groups of han-
dles—or even shift–drag-enclose additional groups.

• Choose the appropriate command from the MIDI Tool Menu. Set To gives all selected 
notes a velocity value you specify. Scale creates a smooth gradation from one value to another 
(ideal for crescendo effects). Add alters every selected note’s velocity by a value you specify. 
Percent Alter alters a note’s velocity by a percentage of its current value. Limit lets you spec-
ify a maximum and minimum velocity value for the selected notes. Alter Feel gives you selec-
tive control over downbeats, offbeats, and backbeats, letting you alter each by an absolute or 
percentage of current value (ideal for “boosting the backbeat”—in other words, making the 
backbeats louder). Randomize changes the selected notes’ velocities by a random amount, to 
the degree you specify (ideal for giving a more human “feel” to the piece).

• If you want to hear the effects of your work along the way, choose Play from the MIDI 
Tool Menu. It’s important to understand that you’re editing the performance data of the 
selected music. Performance data is a set of velocity (and Start and Stop Time) playback infor-
mation that Finale associates with each note in the score. At any point, you can hear your 
music played strictly as it appears in the score, or you can hear it played using the captured 
MIDI data.
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If the music you’re editing was a transcription you made from a performance in Transcription 
Mode, and if you clicked Save Key Velocities before transcribing, in the MIDI Tool you’d see 
(and be able to edit) the actual key velocities of the notes as you originally played them.

• When you’re finished, close the MIDI Tool split-window. In order to hear the changes you 
made, choose Playback Controls from the Window Menu. Click the expand arrow, and then 
Playback Options. Make sure Play Recorded Key Velocities is selected. If it is, you’ll hear the 
score played back using the performance data—in other words, you’ll hear the effects of your 
velocity editing whenever you play back your score.

To copy or erase key velocity data
See MIDI—To copy or erase captured (or edited) MIDI data.

To affect the key velocity of a single note (Articulations) or Expressions
See ARTICULATIONS; CRESCENDO/DECRESCENDO; DYNAMICS.

To record key velocity information
For complete information on recording with the HyperScribe Tool, see TRANSCRIBING A 
SEQUENCE, RECORDING WITH HYPERSCRIBE and Installation & Tutorials.

• After recording a performance in the Transcription Mode, click Save Key Velocities. 
Transcribe the performance in the usual way. Or, if you’re using HyperScribe, choose 
HyperScribe Options from the HyperScribe Menu. Make sure that Record Key Velocities is 
selected.

• Choose Playback Options from the Options Menu. The Playback Options dialog box 
appears.

• Select Play Recorded Key Velocities and click OK. When Play Recorded Key Velocities is 
selected, Finale uses the original key velocity information it recorded when you created the 
performance—even if you edit the durations of notes in the score. You can edit the captured 
velocity information visually by using the MIDI Tool (see “To edit key velocity with the MIDI 
Tool,” above).

Limiting MIDI data
You can use the MIDI Tool to limit certain MIDI data for selected regions. In particular, you can 
limit the note velocities, Start and Stop Times, pitch wheel values, Channel Pressure values, and 
other MIDI continuous data to within a certain range. For example, if you specified a maximum 
velocity of 90 for a given region, any note whose velocity value is between 91 and 127 would be 
clipped down to 90.

For a more complete description of the Limit function, see LIMIT DIALOG BOX. For specific infor-
mation on limiting MIDI controller and wheel data, see CONTINUOUS DATA.

Patches
In the world of MIDI music, there doesn’t seem to be a consensus as to how to refer to the differ-
ent sounds available from any MIDI device. Different manufacturers may refer to a specific violin 
sound (for example) on their MIDI device as a sound, patch, part, voice, or program. This can be 
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very confusing when all you want to do is change the trumpet sound to the saxophone sound. In 
the interest of consistency throughout Finale and its documentation, we’ll refer to a specific sound 
as a Patch. This term comes from the early days of the synthesizer, when you changed the sound 
of your synthesizer by switching the configuration of the various “patch” cords or cables.
A patch could be as simple as a basic MIDI program change message, but it might also include 
bank change information, which may be required on certain MIDI devices to access all available 
patches.
Finale both records and plays back the MIDI data that causes a MIDI instrument to change 
patches (that is, programs or sound settings and optional bank change information) during play-
back. You can even edit this data directly using the MIDI Tool. Using Finale’s Instrument List, 
you can create sets of your favorite channel/patch combinations and select them, by name, from 
the Instrument drop-down list.
Not every MIDI instrument begins the numbering of its programs at 1 (some begin numbering at 
0). Therefore, if you find that the numbers you enter in the following examples change your MIDI 
instrument to a program number that’s one off, remember to change the numbers accordingly by 
adding or subtracting 1. (If your MIDI instrument isn’t responding to the program changes, make 
sure that program changes have been “enabled,” for those synthesizers having such a control.)
The easiest way to set up patches is to select the instrument you want from the General MIDI drop 
down list. This will automatically setup the Bank Select and Program Change for that instrument. 
If you prefer to setup specific Bank Select and Program Change information using the text boxes, 
the direction below provide more information.

To establish the initial program settings for each staff
• From the Window Menu, choose Instrument List. The Instrument List window appears.

• In the Prog. column, enter the MIDI instruments patch number you want for each staff. 
If you want to assign a program to a certain layer of a staff, click the upward arrow next to a 
staff name; the list expands to show you individual layer assignments.

The Instrument List gives you a great deal of power over MIDI channels and patch assign-
ments. See PLAYBACK and MIDI CHANNELS for details. For the moment, note that Finale 
won’t actually transmit this patch-change information to your MIDI instrument unless you’ve 
told it to do so:

• From the bottom on the Instrument List window, select Send Patches Before Play. 

To set up a patch change on playback
These instructions tell you how to create an expression marking that produces a patch change dur-
ing playback (such as “To strings”). If you don’t need a visual indication to appear in the score, 
you may find it faster to use the MIDI Tool to create patch changes (see “To set up patch changes 
using the MIDI Tool,” below).

• Click the Expression Tool y. 

• Click on, above, or below the note at which you want the patch to change. The Expression 
Selection dialog box appears. If you’ve previously created the patch change marking, double-
click it. The expression appears in the score, where you can adjust its position (see below).

• Click Create. The Text Expression Designer dialog box appears.
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• Type a patch change indication (“To Clarinet,” for example). You can label the patch 
change any way you like, or you can leave the text box empty (if you want no graphic marking 
at all).

• Click Playback Options. The Text Expression Designer dialog box expands.

• From the Type drop-down list, choose Patch. 

• The Patch drop-down list appears, choose the type of patch change needed, select the 
appropriate Bank and Program changes. 

• Click OK or Select in each dialog box until you return to the score. If you begin playback 
at a point in the score after the patch change indication, Finale won’t “know about” the patch 
change, and you’ll hear the staff play back using the initial patch.

You can, however, tell Finale to “chase” the patch changes up to the point where you’re begin-
ning playback. That is, Finale will quickly scan the piece all the way from the first measure, 
noting (and transmitting to your MIDI keyboard) any patch changes along the way, so that 
playback always begins using the current patch. See “To ‘chase’ patch changes before play-
back,” below.

To “chase” patch changes before playback
• Choose Playback Controls from the Window Menu. The Playback Controls appear.

• Click the expand arrow, and then Playback Options. The Playback Options dialog box 
appears.

• From the Dynamics and Markings drop-down list, choose Chase from 
First Measure, then click OK. When you click a measure in the middle of a piece to begin 
playback, Finale will take a moment to scan your piece and “chase” any patch change mark-
ings that occur earlier in the piece up to the measure you clicked. In this way, Finale can keep 
track of any patch changes it encounters along the way, so that playback always begins with 
the correct current patch.

To set up patch changes using the MIDI Tool

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. The MIDI 

Tool Menu appears.

• Double-click the measure in which you want the patch to change. The MIDI Tool split-
window appears.

• From the MIDI Tool Menu select Continuous Data. The Continuous Data dialog box 
appears, choose Patch Changes and click OK. On the left-side of the MIDI Tool split-window 
you see a scale of continuous-data values—from 1 to 128. Unless you’ve already created patch 
changes with the MIDI Tool (or recorded them during a Transcription Mode performance), the 
window is empty.

You’ll specify where you want to insert a patch change by dragging through a sliver of the 
graph area.
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• Drag through a small horizontal “slice” at the beginning of the graph area, as shown. 
Keep in mind that the actual patch change will occur at the beginning of the region you select 
(indicated by the arrow in the figure below). It really doesn’t matter, therefore, how much of 
the window you highlight; the patch change will be inserted at the far left edge of your high-
lighted region.

• Choose Set To from the MIDI Tool Menu. The Set To dialog box appears.

• Enter the appropriate Bank and Program numbers you want the staff’s playback to 
switch to. Click OK (or press enter). You return to the MIDI window. Part of the graph area 
is now black. That’s because you’ve just inserted a patch change that’s in effect from the point 
you selected to the end of the piece. Repeat the entire process at other points in the score 
where you want the patch to change (for example, if you want the patch to change back to the 
original patch).

To remove patch changes you’ve created in this way, reselect the same region and press back-
space or use the Mass Mover Tool to clear Continuous Data.

To copy or erase patch change data created with the MIDI Tool
See MIDI—To copy or erase captured (or edited) MIDI data.

Pitch wheel
As you move the pitch wheel up or down (on MIDI keyboards so equipped), the pitch of the entire 
keyboard shifts up or down by an amount you program on the MIDI keyboard itself. Finale 
records and plays back pitch bends (the smoothly graduated, continuous shift of pitch that occurs 
when you use the pitch wheel). You can also edit pitch bends that you’ve recorded, and you can 
even insert expressions whose playback definitions involve the use of the pitch wheel.

When you record a performance with the Transcription Mode, Finale automatically records all 
your pitch wheel data. You may or may not want this information retained so that you can later 
hear it applied to the playback of your transcription. For a full description of captured MIDI infor-
mation, see Installation & Tutorials.

To retain pitch wheel data for score playback
• Record a performance that includes pitch wheel data with the Transcription Mode. See 

TRANSCRIBING A SEQUENCE for instructions on recording a performance.
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• Before saving or transcribing the performance, click Save Continuous Data. If Play 
Recorded Continuous Data is selected in the Playback Options dialog box (accessed by click-
ing the expand arrow in the Playback Controls), you will hear your pitch bends when you play 
back the transcription.

To edit pitch wheel data

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. 

• From the MIDI Tool Menu, choose Continuous Data. The View Continuous Data dialog 
box appears, from which you can choose the MIDI data you want to edit.

• Click Pitch Wheel, and click OK.

• Select the measures you want to affect. Click to select one measure, shift-click to select 
additional measures, drag-enclose to select several on-screen measures, click to the left of the 
staff to select the entire staff, or choose Select All from the Edit Menu to select the entire doc-
ument.

If the region you want to edit is on only one staff and fits on the screen, double-click the high-
lighted region to enter the MIDI Tool split-window. Drag through the display area above the 
notes whose pitch wheel data you want to edit.

• Edit the selected region by choosing the appropriate command from the MIDI Tool 
Menu. In the following discussion, it’s useful to remember that when the pitch wheel is at 
rest, its value is 0; when it’s as far down as it can go, its value is -8192; and when it’s at the top 
of its range of movement, its value is 8191.

Choose Set To to specify a uniform value for the pitch wheel level in the selected region. 
Choose Scale to create a gradual change in pitch wheel values over the selected region. 
Choose Add to add a positive or negative amount to the pitch wheel level throughout the 
selected region. Choose Percent Alter to change the pitch wheel values in the selected region 
by a percentage of their original amounts. Choose Limit to specify a maximum or minimum 
pitch wheel value for the notes in the selected region. (See also SET TO DIALOG BOX; SCALE 
DIALOG BOX; ADD DIALOG BOX; PERCENT ALTERATION DIALOG BOX; or LIMIT DIALOG BOX.)

For the most part, you’ll use the Scale, Limit, or Set To commands. For example, to create a 
smooth pitch bend that rises for two beats and then falls for two beats, you’d proceed as fol-
lows: Drag through the graph display region of the MIDI Tool split-window, so that two beats 
are highlighted. Choose Scale from the MIDI Tool Menu; in the text boxes, enter 0 (the pitch 
wheel’s “at rest” value) and 8191 (the pitch wheel’s highest position). In the third text box 
(Increments), enter 640 (for example); the smaller this number, the smoother the pitch bend 
will be, but the more data Finale will need to generate and store, and hence the larger your 
document will be. Click OK. Next, drag through the second two beats and choose Scale again 
from the MIDI Tool Menu. This time enter 8191 in the first text box and 0 in the second (to 
bring the pitch wheel back to its normal-pitch position); enter a value in the Increments box 
and click OK. You’ll see the effects of the pitch bend you just programmed in the graph area of 
the MIDI Tool split-window—and you’ll hear it when you choose Play from the MIDI Tool 
Menu.
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If you create a pitch bend that isn’t quite calculated correctly, you may discover that, during 
playback, the pitch of your MIDI keyboard never fully returns to normal. That’s because the 
pitch wheel, via MIDI, gets “stuck” partway out of its at-rest position. If this happens, drag 
through part of the graph area of the MIDI Tool split-window (at the place where you want the 
pitch wheel to be returned to its at-rest position), choose Set To from the MIDI Tool Menu, 
enter 0, and click OK.
You can also remove pitch bend data from regions of your score by following the instructions 
above but, instead of following the last instruction, pressing backspace or use the Mass Mover 
Tool to clear Continuous Data.

To copy or erase pitch wheel data
See MIDI—To copy or erase captured (or edited) MIDI data.

To create a pitch bend (as an expression)
The following instructions show you how to create an expression that produces a smooth pitch 
bend over the course of one whole note—from the pitch wheel’s at-rest position to its top position 
and back down again. It’s impossible to predict the precise musical effect this will have on your 
MIDI keyboard, because the pitch wheels on different MIDI keyboards have different intervallic 
ranges; on some, you can specify this range (usually up to an octave or so up or down).
If you want to learn the process of creating a pitch wheel expression, by all means follow this 
example. You may prefer, however, simply to load the pitch wheel library that’s in your Libraries 
folder, because this library already contains the expression you’re about to create with the excep-
tion that it only lasts a quarter note instead of a whole note. Choose Open Library from the File 
Menu. Locate the Pitch Bend Library (in the Libraries folder), and double-click it. Then place it 
into your score as described below.

• Click the Expression Tool y. Click on, above, or below the note to which you want to 

attach the marking. The Expression Selection dialog box appears. If the pitch bend expres-
sion marking already appears in the list (because you’ve loaded the Pitch Bend Library, for 
example), double-click it and click OK; you return to the score.

• Click Create. The Text Expression Designer dialog box appears. Type “Pitch bend” (or what-
ever text you want to appear in the score, if any, at the location of the pitch bend). Click Set 
Font to change the type style.

• Click Playback Options. The Text Expression Designer dialog box expands.
• From the Type drop-down list, choose Pitchwheel. Click Execute Shape, then the Execut-

able Shape Select button. Proceeding through the dialog boxes, click as follows: Create; 
Shape ID; Create. You’re now in the Shape Designer.

• Choose Rulers and Grid from the Shape Designer Menu, and select Eighth Notes. Type 4 
in the Grid Marks Every ___ 8th notes text box. Click OK. Choose Grid from the Show 
submenu of the Shape Designer Menu, if you wish.

• Choose 25% from the View drop-down list. When you use the Shape Designer to create a 
pitch bend, the range of pitch wheel values is from -8192 (pitch wheel at the bottom of its 
range) to 8191 (pitch wheel at the top of its range). The pitch wheel’s value when it’s “at rest” 
is 0.
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Because these values are so large, you’ve just reduced the Shape Designer display so that 
you’ll be able to see the entire shape in the window at once. (You should also click the Hand 
Grabber tool and drag so that the small white circle is closer to the lower-left of the drawing 
area.) You’re about to design an Executable Shape—a shape whose contour governs the effects 
of the pitch bend. For more on Executable Shapes, see EXPRESSIONS—To define an expression 
for playback.

• Click the Multiline Tool W. To use the Multiline tool, you drag to create the first line seg-

ment, click at each subsequent corner, and then double-click to complete the shape. To make 
your shape match the dimensions of the one pictured here, observe the H: and V: numbers as 
you move the cursor, and place your mouse clicks according to the table below. (Of course, 
you can always drag individual points into position, using the Selection Tool, after you’ve 
drawn the shape.)

• Draw the shape as shown: 

You should have a tall, upside-down V. This Shape Expression first bends the pitch wheel up, 
and then back down to its original position.

• Click OK twice to exit the Shape Designer. 

• In the Level Scale boxes, enter 128:1. Remember that a pitch wheel’s actual “all-the-way-
up” value is 8191. By multiplying the height of the shape you drew by 128, you’re telling 
Finale to make the pitch bend 128 times more pronounced; if you didn’t, you probably 
wouldn’t even be able to perceive the pitch bend. 

The shape you drew was 32 eighth notes (4 measures) long. The reason for this is to create a 
smoother sounding pitch bend.

Action
H: 

value

V: 
valu

e

Start at... 0 0

Drag to... 16 64

Double-click... 32 0

2

1 3
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• Change the Time Scale. Enter a 1:4 Time Scale ratio to make the pitch bend last only 1/4 as 
long (a whole note); enter 2:1 to make it last twice as long, and so on. The shape in the pitch 
bend library has a Time Scale ratio of 1:16 to last only a quarter note.

• Click OK or Select in each dialog box until you return to the score. Listen to the pitch 
bend in playback and see how it works. If you want it to be less pronounced, decrease the 
Level Scale (or change the maximum pitch bend interval on your MIDI keyboard). If it lasts 
too long, decrease the Time Scale.

If you entered text for the pitch bend expression, click the note to which it was attached; the 
expression’s handle appears. Drag this handle to move the expression; click it and press delete 
to remove it.

Start and Stop Times
See also SWING.

Start Times and Stop Times, which you can edit directly with the MIDI Tool, essentially refer to 
the attack and release of a note. They don’t refer to the notated durations of the notes; instead, 
they relate those notated values to the captured MIDI data. Captured MIDI data is the MIDI infor-
mation generated by your original performance in HyperScribe, before it’s quantized and tran-
scribed into notation.
The terms Start Time and Stop Time refer specifically to the difference between the quantized 
duration of a note (that is, its starting and ending points when given its full notated value) and 
your actual attack and release of the note in your performance. In the figure below, the indicated 
Start Time is a positive number (because the note was played slightly after the beat), and the Stop 
Time is a negative number (because the note was released slightly before the next beat):

The Start Time is the difference between the actual (performed)attack point and the notated, quan-
tized attack point. The Stop Time is the difference between the actual (performed)release point and 
the notated, quantized release point. These differences can be either positive or negative; Stop Time 
(a), above, is a negative number—because the note was released early—but Stop Time (b) is posi-
tive. 

Start and Stop Times

qqqq qqqqqqqq

These bars represent the
durations of the notes you
played using Transcription 
Mode...

... that Finale quantizes, or
rounds to the nearest beat...

... to produce notation.

Start Time

Stop Time

(a) (b)
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Start and Stop Times are measured in very small rhythmic increments called EDUs (ENIGMA 
Durational Units), of which there are 1024 per quarter note. (A full table of EDU equivalents 
appears in the Equivalents section of the Appendix, see EQUIVALENTS.) If you hold down each 
note you play for precisely its notated value, with 1024th-beat accuracy, the Start and Stop Times 
will both be zero, with no difference between the quantized and the actual attack point of the note. 
Of course, no human can play that precisely.

For a more complete discussion of Start and Stop Times and the MIDI Tool, see Installations & 
Tutorials.

To edit the start and stop times of selected notes

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p, and select 

the region whose playback data you want to edit. Click to select one measure, shift-click to 
select additional measures, drag-enclose to select several on-screen measures, click to the left 
of the staff to select the entire staff, or choose Select All from the Edit Menu.

• If the region you wish to edit is on one staff, double-click the highlighted area to enter the 
MIDI Tool split-window. Select the specific notes whose Start and Stop Times you want 
to edit. Once you’re in the MIDI Tool split-window, you can select entire regions of notes by 
dragging through the “graph” area of the window. You can also select specific notes to edit by 
selecting their handles (in the notation display at the bottom of the window). Select one handle 
by clicking, additional handles by shift-clicking, a group of handles by drag-enclosing, and 
additional groups by shift–drag-enclosing.

• From the MIDI Tool Menu, choose Note Durations. Once you’ve selected the notes to be 
affected, you can apply one of the MIDI Tool’s Menu commands:

• Choose the desired command from the MIDI Tool Menu. Each command brings up a dia-
log box in which you can specify how the selected notes are to be altered. Set To allows you to 
give every note in the selected region the same Start or Stop Time. In this way, you can shorten 
or delay all notes by the same amount. Scale gradually shortens (or lengthens) the Start or 
Stop Times of the selected notes from one value to another. Add alters every selected note’s 
Start or Stop Time by a positive or negative value you specify. Percent Alter increases or 
decreases the selected notes’ durations by a percentage of their current values—ideal for cre-
ating a staccato effect for the selected music. Limit lets you set a maximum and minimum 
Start Time and Stop Time value for the selected notes, in effect pulling the beginning and end-
ing of each note closer to the beat. You can think of the Limit command as a form of quantiz-
ing. 
The Alter Feel command changes the Start and Stop Times of Downbeats, Other Beats, and Back-
beats. (Backbeats are defined as the half beats [in a duple meter] or the second and third offbeats [in 
a triple meter]. For some interesting uses of the Alter Feel command, see SWING.) Finally, Random-
ize alters the selected notes’ durations by a random amount, giving the music a less quantized, more 
human feeling. You might enter an EDU value of 1⁄16 (or less) of the predominant rhythmic values in 
the music; to subtly soften the rhythmic precision of an eighth note (512 EDUs) passage, for exam-
ple, you might type 32 into the Start and Stop Times boxes.

• Enter the desired degree of Start or Stop Time modification, and click OK. 
• Close the MIDI Tool split-window by clicking the MIDI Tool. 



Volume 40-41      

OC

OC

ndex

Index

ext 
hapter

ext 
hapter

revious
hapter

revious
hapter
T

T

I

N
C

N
C

P
C

P
C

To erase Start and Stop Time editing done with the MIDI Tool

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. The MIDI 

Tool Menu appears. Make sure Note Durations is still selected in the menu.
• Select the region in which you edited Start and Stop Times, and press backspace Or, use 

the Mass Mover Tool to clear Continuous Data. 

To copy Start and Stop Time editing done with the MIDI Tool

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. The MIDI 

Tool Menu appears. Make sure Note Durations is selected in the menu.
• Select the region in which you edited Start and Stop Times. 
• Drag the first source measure so that it’s superimposed on the first target measure. If the 

first target measure is not on-screen, scroll until you see it. Then, while pressing ctrl and shift 
simultaneously, click the first target measure.
In either case, the Copy MIDI Data dialog box appears.

• Type the number of times you want to copy the material (horizontally). Click OK. The 
Start and Stop times are copied onto the notes which fall on the same rhythmic location as 
source notes.

To create a legato playback

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. The MIDI 

Tool Menu appears.

• Select the region you want to sound more legato. See SELECTING MUSIC for more informa-
tion.

• From the MIDI Tool Menu, choose Note Durations.

• From the MIDI Tool Menu, choose Percent Alter. The Percent Alter dialog box appears.

• Enter 105 and click OK.

Volume
See also KEY VELOCITY; CONTINUOUS DATA.

When you’re working with MIDI music information, there are two ways to control the volume of 
playback. The most common way is to control the key velocity of each note—that is, how hard it 
is “struck” when it’s played by the computer. Usually (but not always), MIDI keyboards respond 
to key velocity information the same way a piano does: the harder the note is struck, the louder it 
sounds. See KEY VELOCITY for more information.

Key velocity has one limitation, however: it can’t control the volume of a note after it’s been 
struck. For piano music, this is no problem. But imagine a long note played by a trumpet—the 
player can swell and diminuendo within the same note. To create this kind of effect, you can use a 
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second volume-control method: MIDI volume controller information. MIDI Volume is controller 
number 7; see CONTINUOUS DATA for instructions on creating and editing this and other controller 
data.

MIDI
MIDI, or Musical Instrument Digital Interface, is the computer language that computers and 
MIDI instruments use to speak to each other. If you need help setting up your MIDI system, con-
sult “Setting Up Your MIDI System” in Installation & Tutorials. If you’re interested in some of 
the technical aspects of MIDI, see the APPENDIX–MORE ON MIDI.

Dozens of Finale features make use of MIDI. If you’re interested in affecting MIDI playback 
through the use of graphic expression marks, see EXPRESSIONS (or see the entry for the individual 
marking). If you want to edit a specific MIDI data type, see the entries KEY VELOCITY; START 
AND STOP TIMES; PATCHES; CONTINUOUS DATA; and PITCH WHEEL.

If you’re interested in step-time MIDI input, see SPEEDY ENTRY. For information on recording 
and transcribing real-time MIDI performances, see RECORDING WITH HYPERSCRIBE and TRAN-

SCRIBING A SEQUENCE.

To create or transcribe a standard MIDI file for exchanging with sequencer programs, see MIDI 
FILES–To export a MIDI file.

To assign the staves in a piece to MIDI playback channels, see MIDI TERMINOLOGY–MIDI chan-
nels. For information on sending patch changes, see PATCHES. To synchronize Finale’s MIDI 
input or output to that of an external sequencer or another computer, see MIDI SYNC.
 You have a wide range of MIDI driver choices and can send and receive MIDI on more than one 
instrument per port. Furthermore, you can choose from a possible 64 channels. 

To copy or erase captured (or edited) MIDI data
Once you’ve either captured MIDI data (by clicking one of the Save [MIDI data] checkboxes after 
recording in Transcription Mode) or edited MIDI data in the score (using the MIDI Tool), you can 
either copy this MIDI data to other parts of the score or erase it completely from a selected region. 
For example, if you’re creating a piano piece in which the sustain pedal should be pressed at the 
beginning of each measure and released at the end, you only have to create this pattern of MIDI 
controller data once using the MIDI Tool. Thereafter, you can simply copy the “pedaling” data 
from that one measure to any other measures in the score.

When you “erase” MIDI data, you’re erasing variations from the default value of the particular 
MIDI data you’re editing. For example, if you erase Key Velocity data from a region, you’re effec-
tively restoring the default velocity value (such as 64) to every note in the region. (You set this 
default velocity value in the Base Key Velocity box [choose Playback Controls from the Windows 
Menu, click the expand arrow].) Similarly, if you erase Note Duration (Start/Stop Time) data from 
a region, you’re erasing the difference between the notated attacks and releases of the notes and 
the actual attack and release points (as recorded in Transcription Mode or edited with the MIDI 
Tool). In short, you’re restoring the playback of the selected region to a straightforward, “perfect” 
rhythmic feel.

• From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. The MIDI 

Tool Menu appears.
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• From the MIDI Tool Menu, select the MIDI data type you want to erase or copy. Choose 
Key Velocities, Note Durations, or Continuous Data; if you choose Continuous Data, a dialog 
box appears so that you can specify which kind of MIDI continuous data you want to edit. 
Click the appropriate button (Sustain Pedal, Modulation Wheel, and so on), or enter the con-
tinuous data number in the text box. Click OK.

• Select the region whose playback data you want to affect. Click to select one measure, 
shift-click to select additional measures, drag-enclose to select several on-screen measures, 
click to the left of the staff to select the entire staff, or choose Select All from the Edit Menu.

• To erase the selected MIDI data type from the selected region, press backspace or use the 
Mass Mover Tool to clear Continuous Data. 

• To copy the selected MIDI data type to another region, drag the selected region so that 
it’s superimposed on the first target measure. If the first target measure is not on-screen, 
scroll until you see it. Then, while pressing ctrl and shift simultaneously, click the first target 
measure.

The Copy MIDI Data dialog box appears (unless the first target measure is directly above or 
below the first source measure).

• Type the number of times you want the material (horizontally) copied. Click OK (or 
press enter). 

To send an All Notes Off message
On rare occasions, you may encounter a situation called MIDI lock, in which your synthesizer is 
“stuck” on a certain note or chord.

• Choose All Notes Off from the MIDI Menu. Finale sends an “all notes off” message to 
every note of every channel. You should find that, after a moment, the situation is corrected.

To correct erratic MIDI playback
If you’re working with a very “notey” score, you may at times find that your computer gets over-
whelmed by the amount of MIDI data it’s asked to play. For suggestions, see PLAYBACK—To cor-
rect erratic MIDI playback.

To specify the MIDI port
Before specifying a MIDI port, you must first install the MIDI device (MIDI card) in your com-
puter, and its driver in the Windows Control Panel. For details, consult your MIDI Device manual.

• Choose MIDI Setup from the Options Menu. The MIDI Setup dialog box appears.

• Specify the MIDI IN Device (from which you want to receive MIDI input). While Finale 
can play back up to eight MIDI cards, it only records from one port at a time, and will not 
address the MIDI channels on all eight cards discretely.

• For MIDI OUT or playback, specify the devices from the drop-down list. If you have 
more than one MIDI card installed, specify which one you want to carry MIDI channels 1 
through 16 by entering the number in the Base Channel field.

• Click OK (or press enter). 
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To change a MIDI channel in mid-staff
To change a staff’s MIDI channel within a piece, you create an expression that’s been defined for 
playback as a MIDI channel number.

• Click the Expression Tool y. 

• Click on, above, or below the note to which you want to attach the channel-change 
expression. The Expression Selection dialog box appears.

• Click Create. The Text Expression Designer dialog box appears.

• Type the text for your Text Expression. You might want to call an expression that switches 
playback to channel 2 “To channel 2,” for example. Click Set Font to set the type. If you want 
this marking to be invisible, don’t type anything at all; but remember where you clicked to 
“attach” the marking, or you may never be able to find its handle again.

• Click Playback Options. The dialog box expands.

• From the Type drop-down list, choose Channel. Enter the channel number in the Set To 
Value box. Click OK or Select in each dialog box until you return to the score. 

To move or delete the channel-change expression

• Click the Expression Tool y, and click the note to which the expression was attached. 

Its handle appears.

• Drag the handle to reposition the expression; select it and press delete to remove it. 

To assign a staff to more than one MIDI channel
Finale normally allows you to route each staff to a single MIDI channel. For some effects, how-
ever, you may want the staff’s contents transmitted on more than one channel—for example, if 
you want to mix the sounds from two different patches. To create this arrangement, you have to 
create an expression (which can be invisible, if you like) defined for playback. This marking’s 
playback definition involves the creation of a MIDI data dump.

• Click the Expression Tool y; click on, above, or below the note at which the music 

should begin playing over additional MIDI channels. The Expression Selection dialog box 
appears.

• Click Create. The Text Expression Designer dialog box appears.

• Enter the text (if any) for your data dump expression. Click Set Font if you want to specify 
the type style of the new Text Expression. (You can leave the text box blank, if you wish.)

• Click Playback Options. The Text Expression Designer dialog box expands.

• From the Type drop-down list, choose Dump. The Playback Data Dump dialog box 
appears.

• In the Number of Units text box, enter 2 or 3 (depending on whether you want the staff’s 
playback routed to 1 or 2 additional MIDI channels). A staff can play over up to three 
MIDI channels, including the primary MIDI channel you’ve established for the staff.

• In the first Data box, enter $FF. This code, including the dollar sign, is a special notation 
that tells your MIDI Instrument to prepare to receive additional MIDI channel information.
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• In the next Data text boxes, enter one or two numbers, corresponding to the MIDI chan-
nels you want the staff’s playback routed to minus one. In other words, if you want the 
staff to play over channels 5 and 6 (in addition to its primary MIDI channel), enter 4 in the 
second Data box and 5 in the third. (Also be sure to delete the default “$00” value from each 
text box before entering your MIDI channel numbers.)

When Finale plays your score and reaches the expression you’re creating, it will reroute the 
playback to the MIDI channels you’ve just specified.

• Click OK or Select in each dialog box until you return to the score. You return to the score.

Technical note: Here are some other codes you may find useful if you plan to make extensive 
use of the Data Dump feature. If, at some point in the staff, you want to change only one of the 
additional two MIDI channels you’ve specified, create another expression. Define this expres-
sion, too, to have a Data Dump Playback Definition; however, in the Data text box that origi-
nally displayed the MIDI channel that you don’t want to change at this point, enter the code 
$FE. Example: Your first Data Dump expression added channels 5 and 6 to the staff’s play-
back; its Data boxes displayed $FF, 4, and 5. You want the additional channels now to be 5 and 
12, so you create a new Data Dump expression; its Data boxes should display $FF, $FE, and 
11. 

Finally, you can “turn off” any additional MIDI channels you’ve specified with a Data Dump 
expression by entering $FF in the appropriate Data box. Example: Your first Data Dump 
expression added channels 5 and 6 to the staff’s playback; its Data boxes displayed $FF, 4, and 
5. You now want channel 5 to drop out, so you create a new Data Dump expression; its Data 
boxes should display $FF, $FF, and $FE (because $FE, remember, is the “don’t change this 
channel” command).

MIDI Terminology
Sequencing
Technically speaking, Finale isn’t a sequencing program. Yet it duplicates many functions of a 
sequencer, and has the added advantage of being notation-based.

You’ll find separate entries for TRANSCRIBING A SEQUENCE—To add tracks; CONTINUOUS DATA; 
TEMPO (FOR PLAYBACK); MIDI CHANNELS; MIDI FILES; DYNAMICS; RALLENTANDO; KEY 
VELOCITY; PITCH WHEEL; and so on, all of which affect the playback of your score. You’ll also 
learn about some important sequencer-like features in the Installation & Tutorials, “More MIDI 
Features,” which includes a guided tour of the MIDI Tool. The MIDI Tool can edit the raw MIDI 
data that’s linked to the notated music of the score.

If you plan to use Finale as a quasi-sequencer, it’s important to recognize that Finale can play 
back any score in one of two very different ways. With one setup of the Playback Options dialog 
box, you hear a playback of the notation. It’s an “intelligent” performance, because it responds to 
expression markings such as dynamics, ritards, accents, and so on. Nonetheless, the performance 
will be rhythmically perfect, lacking any of the irregularities in performance that give music a 
human “feel.”
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With a different selection of Playback Options, then, instead of merely playing back the notated 
score, Finale can play back the score using captured MIDI data. Captured MIDI data is the actual, 
unquantized MIDI “recording” of a performance you created using the Transcription Mode, includ-
ing your key velocity information, your ritards, and your pedaling. (HyperScribe only captures 
some of this information.) What’s even more useful is that once you’ve transcribed such a perfor-
mance, you can edit the notes, the dynamics, and other elements of the notated score; when you 
play the performance-data version, you’ll hear your changes incorporated into the original perfor-
mance.

In brief, you must “capture” this MIDI data while you’re still in Transcription Mode by clicking 
the two Save checkboxes at the lower-left corner of the window: they refer to MIDI continuous 
data, and tempo information. Also making sure that Key Velocity and Note Duration are selected 
in the More Quantization Settings dialog box under the Options Menu (choose Quant Settings 
then click More). These Quantization Settings also affect HyperScribe.

Then, after you’ve transcribed the performance into notation, select the corresponding four Play 
checkboxes in the Playback Options dialog box (accessed from the Playback Controls). For a 
more complete discussion of captured MIDI data, see Installations & Tutorials.

MIDI Setup
A MIDI setup is the physical connection between all your MIDI devices and your computer. A 
typical setup consists of a MIDI interface, a computer, and the actual MIDI equipment such as 
keyboards, sound modules, wind controller, and so on.

MIDI System

A MIDI system is any part of the operating system that handles communication between Finale 
(or any other software application) and a MIDI setup.

MIDI Interface
A MIDI interface is an external device that translates signals between your computer and MIDI 
instrument(s). 

MIDI channels
If you plan to work extensively with staff-to-MIDI channel mappings, you should become famil-
iar with the concept of Instruments. An Instrument is one distinct stream of playback information; 
you might think of an Instrument as one player’s part.

An Instrument is usually one staff in your score, but it doesn’t have to be. For example, you’ll 
probably want to write a piano part on two staves, but those two staves are considered just one 
Instrument (and thus they’ll use the same MIDI channel). On the other hand, each layer of each 
staff can be considered a different Instrument; you might write two clarinet parts on a one staff (in 
different layers), but you can tell Finale to treat them as two Instruments. 

Each Instrument can have its own MIDI channel, and each Instrument is dynamically indepen-
dent. If you want the treble and bass staves of a piano part to have independent dynamics, make 
sure you assign them to different Instruments.

There are 64 possible Instruments in Finale. If you don’t change Finale’s original settings, Finale 
treats each staff as a separate Instrument; for simple playback, you’ll probably never need to 
change this arrangement.
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For more complex playback situations, however, you’ll find that Finale’s Instrument List window 
gives you a lot of power and control with very little effort. As a matter of fact, we’ve included 
Instrument Libraries—preconfigured instrument, channel, and patch setups—for many popular 
MIDI keyboards. See “To load an Instrument Library.”

MIDI Channels and Patches
Each MIDI instrument is able to receive MIDI information on one or more of 16 MIDI channels. 
Some instruments only play back using one channel at a time. Other instruments are multi-tim-
bral, meaning that they can play back more than one channel at a time. In other words, you can 
play different sounds assigned to different channels at the same time, from the same instrument.

Different sounds within a MIDI instrument have specific numbers assigned to them, called pro-
gram numbers. Depending on the instrument, program 1 may be a grand piano sound, program 2 - 
electric piano, program 3 - violin, program 4 - viola, and so on. Some of the more sophisticated 
sound modules can contain many hundreds of sounds. However, MIDI only supports the use of 
the first 128 patch numbers (numbered 0 through 127). To use some of the additional sounds 
“above” patch 127, renumber them as lower patch numbers, or set them manually on the instru-
ment before playing back. To accommodate more than 128 sounds many MIDI devices use banks 
of sounds. Banks are an isolated group of 128 programs, which are accessed by changing your 
“active” bank of programs to a new bank of programs using a special controller message. Bank 
information, combined with program information, creates what is referred to as a Patch.

To have different programs play back at the same time, you need to use different channels with a 
specific patch assigned to each channel. For example, if you wanted to play back a piece for a trio 
consisting of flute, violin and piano, you would set up the piano staves to play back on channel 1, 
program 1; the flute staff to play back on channel 2, program 72; and the violin staff to play back 
on channel 3, program 41. These settings reflect the General MIDI program numbers. Each MIDI 
instrument can be different, so refer to the device’s documentation for a reference to its programs.

Finale Instruments and Channels
There are 64 Finale channels available for MIDI. Since each instrument in Finale’s Instrument 
List allows you to specify a unique channel and patch combination, you can define up to 64 differ-
ent instruments.

Finale makes 64 channels available, but each MIDI device only has 16. Using the MIDI Setup dia-
log box, you can assign each bank of Finale channels to the 16 MIDI channels on a particular 
MIDI device. By assigning an instrument to a staff in the Instrument List, you tell Finale which 
device should play that staff’s information and furthermore, which of the device’s channels Finale 
should use. For example, if you had two devices, one using the first bank of 1-16 and the other 
using the second bank of 17-32, assigning a Finale instrument to channel 17 would cause it to play 
back on the second device’s first channel.

Depending on your MIDI setup, you could map four different devices to their own bank of chan-
nels, or overlap them. In the following example, Finale’s 64 channels are mapped to each of the 
four devices and their 16 MIDI channels.

Finale 
Channels

MIDI channels on the connected 
instrument

1-16 Device One’s channels 1-16
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For entering notes with MIDI using HyperScribe, enter any number between 1 and 64 for the 
Finale channel that will receive the MIDI information. You can also remap the input channels 
using Finale’s MIDI Thru dialog box. See MIDI THRU DIALOG BOX.

For MIDI playback from Finale, you can either use the Instrument List to assign the channels to 
staves in your score, or you can create expressions to change a staff's channel during playback. 
Enter any number between 1 and 64 for the Finale channel used for playback. Finale will direct 
the playback to the appropriate device.

Regardless of whether you use the Instrument List or create expressions, Finale refers to settings 
in the MIDI Setup dialog box to see what Input or Output device is assigned to the channel you 
selected. Finale channels 1–16 go directly to channels 1–16 of the specified Input or Output 
device. The remaining three sets of Finale channels are mapped to channels 1–16 of the specified 
Output or Input device for that bank of channels. For example:

Input Device and Output Device
Input Device and Output Device options in the MIDI Setup dialog box let you choose where you 
want MIDI information sent or received. 

Note: You can’t assign the same input or output device to more than one bank of Finale chan-
nels—after all, each device only uses 16 channels. You can, however, select more than one device 
for a bank of Finale channels. This allows you to double the number of devices playing the 
affected staves’ music.

17-32 Device Two’s channels 1-16

33-48 Device Three’s channels 1-16

49-64 Device Four’s channels 1-16

Finale 
channels

MIDI channels on the connected instrument

1-16 1-16

17-32 1-16 (Add 16 to determine the Finale channel.)

33-48 1-16 (Add 32 to determine the Finale channel.)

49-64 1-16 (Add 48 to determine the Finale channel.)

Finale 
Channels

MIDI channels on the connected 
instrument
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	MIDI Tool
	What it does
	This tool lets you edit the actual MIDI data that Finale stores with your music—key velocities (h...
	To use the MIDI Tool, you begin by selecting a region of music whose MIDI information you want to...
	To enter bank and program change data from the MIDI Tool, follow the procedure for entering patch...
	To send bank and program changes immediately, enter the program change and bank select values int...
	Other effects you can create with the MIDI Tool include inserting and editing pitch bends, creati...

	Special mouse clicks

	MIDI Tool Menu
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p.

	What it does
	When you record a real-time performance with the Transcription Mode of HyperScribe, you can tell ...
	This captured data includes key velocity information (how hard you struck each key); Note Duratio...
	Once you’ve transcribed your performance into standard notation, you can listen to it play back i...
	The purpose of the MIDI Tool is to edit the captured MIDI data. You can make a passage louder or ...
	There are two ways to select the section of your notated score whose captured MIDI data you want ...
	If the music whose MIDI data you want to edit is a one-staff region that fits on the screen, sele...
	Once you’ve edited MIDI data (and returned to the score), you can then erase it, or copy it from ...
	To erase the captured MIDI data from a region, be sure the MIDI data type you want to manipulate ...
	For a complete tutorial in the use of the MIDI Tool, see Installations and Tutorials.


	Copy MIDI Data dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p, and select a region of measur...

	What it does
	When you copy MIDI data, Finale offers you the chance to create multiple copies, placed one after...


	Listen dialog box
	How to get there
	Click any Listen button in any MIDI-related dialog box.

	What it does
	Instead of making you type in MIDI codes, Finale often displays a Listen button so that you can p...


	View Continuous Data dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p and select a region of measure...

	What it does
	The MIDI Tool allows you to edit the values of any MIDI continuous data (controllers, wheels, and...


	Set To dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some measures. Specify...

	What it does
	This dialog box’s wording changes to reflect your MIDI data type selection (key velocities, note ...


	Scale dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a region of measures. ...

	What it does
	This dialog box’s wording changes to reflect your MIDI data type selection (key velocities, note ...


	Add dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some measures. (If you...

	What it does
	The Add dialog box’s contents change to reflect your MIDI data type selection (key velocities, no...
	For example, if you’ve selected Key Velocities, you can specify that each note in a selected regi...


	Percent Alteration dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a region of measures. ...

	What it does
	This dialog box’s contents change to reflect your MIDI data type selection (key velocities, note ...
	For example, if you’ve selected Key Velocities, you can specify that each note in a selected regi...


	Limit dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some measures. Specify...

	What it does
	This dialog box’s wording changes to reflect your MIDI data type selection (key velocities, note ...


	Alter Feel dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select some measures. (If you...

	What it does
	The Alter Feel dialog box’s contents change to reflect your MIDI data type selection (key velocit...
	For example, if you’ve selected Key Velocities, you can specify that the downbeat of each measure...
	When you read the following descriptions of the three text boxes, keep in mind that the number in...


	Randomize dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a region of measures. ...

	What it does
	In this dialog box, you can direct Finale to alter the velocity or duration values for all select...
	The wording of the dialog box changes to reflect your MIDI data type selection (key velocities or...


	Edit MIDI Note dialog box
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Select a note handle in the M...

	What it does
	This dialog box simply provides a convenient way to edit the Start and Stop Times and Key Velocit...


	MIDI Tool split-window
	How to get there
	From the Window Menu, choose Advanced Tools. Click the MIDI Tool p. Click to select one measure, ...

	What it does
	The MIDI Tool split-window provides a graphic display of the three kinds of captured MIDI data yo...
	Furthermore, the MIDI Tool split-window offers you an option not available when you use the MIDI ...
	When you edit MIDI data in the MIDI Tool split-window, the changes you make apply to the selected...
	There are several ways to select specific notes in the split-window. To select one, click its han...


	Backbeats
	In Finale, a backbeat is the second half of the beat (in duple meters); thus the second eighth no...
	You can use the MIDI Tool to affect only the backbeats of a piece. You might, for example, boost ...
	To alter the key velocity of backbeats
	To alter the durations of backbeats
	See Swing. Or, see Installation & Tutorials.

	To copy or erase MIDI Tool editing
	See MIDI—To copy or erase captured (or edited) MIDI data.


	Channel Pressure
	Channel Pressure is a type of MIDI information, also called monophonic aftertouch, that describes...
	When you record a performance with the Transcription Mode of HyperScribe, you can specify whether...
	To retain Channel Pressure data for score playback
	To edit Channel Pressure data
	To copy or erase controller data
	See MIDI—To copy or erase captured (or edited) MIDI data.


	Continuous data
	Continuous data is MIDI information that’s not related to individual notes. Usually the term refe...
	This entry describes the general recording, playback, and editing of standard controllers. For in...
	To specify which continuous data you want to record (MIDI Filter)
	Because continuous data consumes memory and disk space, you may opt not to record all types of th...

	To retain continuous data for score playback
	When you record a performance in Transcription Mode, Finale temporarily remembers the continuous ...
	If you’ll later want to hear and edit this data, however, make sure you follow these steps before...

	To edit continuous data
	If you’ve saved continuous data from a performance in Transcription mode, you can edit it directl...

	To copy or erase continuous data
	See MIDI—To copy or erase captured (or edited) MIDI data.


	Downbeats
	You can control both aspects of Finale’s handling of downbeats: graphic and playback. For example...
	If you’re using Finale for playback, you can alter the velocity and durational values for some, o...
	To move all downbeats graphically
	To move a single downbeat graphically
	See Beat positions—To move a beat.

	To alter the key velocity of downbeats
	To alter the attack points of downbeats

	Key velocity
	Key velocity, also called note velocity, is the MIDI data that describes how hard a key was struc...
	There are two ways to affect the key velocity of notes in your score. The quickest method uses th...
	To edit key velocity with the MIDI Tool
	To copy or erase key velocity data
	See MIDI—To copy or erase captured (or edited) MIDI data.

	To affect the key velocity of a single note (Articulations) or Expressions
	See Articulations; Crescendo/Decrescendo; Dynamics.

	To record key velocity information
	For complete information on recording with the HyperScribe Tool, see Transcribing a sequence, Rec...


	Limiting MIDI data
	You can use the MIDI Tool to limit certain MIDI data for selected regions. In particular, you can...
	For a more complete description of the Limit function, see Limit dialog box. For specific informa...

	Patches
	In the world of MIDI music, there doesn’t seem to be a consensus as to how to refer to the differ...
	A patch could be as simple as a basic MIDI program change message, but it might also include bank...
	Finale both records and plays back the MIDI data that causes a MIDI instrument to change patches ...
	Not every MIDI instrument begins the numbering of its programs at 1 (some begin numbering at 0). ...
	The easiest way to set up patches is to select the instrument you want from the General MIDI drop...
	To establish the initial program settings for each staff
	To set up a patch change on playback
	These instructions tell you how to create an expression marking that produces a patch change duri...

	To “chase” patch changes before playback
	To set up patch changes using the MIDI Tool
	To copy or erase patch change data created with the MIDI Tool
	See MIDI—To copy or erase captured (or edited) MIDI data.


	Pitch wheel
	As you move the pitch wheel up or down (on MIDI keyboards so equipped), the pitch of the entire k...
	When you record a performance with the Transcription Mode, Finale automatically records all your ...
	To retain pitch wheel data for score playback
	To edit pitch wheel data
	To copy or erase pitch wheel data
	See MIDI—To copy or erase captured (or edited) MIDI data.

	To create a pitch bend (as an expression)
	The following instructions show you how to create an expression that produces a smooth pitch bend...
	If you want to learn the process of creating a pitch wheel expression, by all means follow this e...


	Start and Stop Times
	See also Swing.
	Start Times and Stop Times, which you can edit directly with the MIDI Tool, essentially refer to ...
	The terms Start Time and Stop Time refer specifically to the difference between the quantized dur...
	Start and Stop Times are measured in very small rhythmic increments called EDUs (ENIGMA Durationa...
	For a more complete discussion of Start and Stop Times and the MIDI Tool, see Installations & Tut...
	To edit the start and stop times of selected notes
	To erase Start and Stop Time editing done with the MIDI Tool
	To copy Start and Stop Time editing done with the MIDI Tool
	To create a legato playback

	Volume
	See also Key velocity; Continuous data.
	When you’re working with MIDI music information, there are two ways to control the volume of play...
	Key velocity has one limitation, however: it can’t control the volume of a note after it’s been s...

	MIDI
	MIDI, or Musical Instrument Digital Interface, is the computer language that computers and MIDI i...
	Dozens of Finale features make use of MIDI. If you’re interested in affecting MIDI playback throu...
	If you’re interested in step-time MIDI input, see Speedy Entry. For information on recording and ...
	To create or transcribe a standard MIDI file for exchanging with sequencer programs, see MIDI fil...
	To assign the staves in a piece to MIDI playback channels, see MIDI Terminology–MIDI channels. Fo...
	You have a wide range of MIDI driver choices and can send and receive MIDI on more than one instr...
	To copy or erase captured (or edited) MIDI data
	Once you’ve either captured MIDI data (by clicking one of the Save [MIDI data] checkboxes after r...
	When you “erase” MIDI data, you’re erasing variations from the default value of the particular MI...

	To send an All Notes Off message
	On rare occasions, you may encounter a situation called MIDI lock, in which your synthesizer is “...

	To correct erratic MIDI playback
	If you’re working with a very “notey” score, you may at times find that your computer gets overwh...

	To specify the MIDI port
	Before specifying a MIDI port, you must first install the MIDI device (MIDI card) in your compute...

	To change a MIDI channel in mid-staff
	To change a staff’s MIDI channel within a piece, you create an expression that’s been defined for...

	To move or delete the channel-change expression
	To assign a staff to more than one MIDI channel
	Finale normally allows you to route each staff to a single MIDI channel. For some effects, howeve...


	MIDI Terminology
	Sequencing
	Technically speaking, Finale isn’t a sequencing program. Yet it duplicates many functions of a se...
	You’ll find separate entries for Transcribing a sequence—To add tracks; Continuous data; Tempo (f...
	If you plan to use Finale as a quasi-sequencer, it’s important to recognize that Finale can play ...
	With a different selection of Playback Options, then, instead of merely playing back the notated ...
	In brief, you must “capture” this MIDI data while you’re still in Transcription Mode by clicking ...
	Then, after you’ve transcribed the performance into notation, select the corresponding four Play ...

	MIDI Setup
	A MIDI setup is the physical connection between all your MIDI devices and your computer. A typica...

	MIDI System
	A MIDI system is any part of the operating system that handles communication between Finale (or a...
	MIDI Interface
	A MIDI interface is an external device that translates signals between your computer and MIDI ins...

	MIDI channels
	If you plan to work extensively with staff-to-MIDI channel mappings, you should become familiar w...
	An Instrument is usually one staff in your score, but it doesn’t have to be. For example, you’ll ...
	Each Instrument can have its own MIDI channel, and each Instrument is dynamically independent. If...
	There are 64 possible Instruments in Finale. If you don’t change Finale’s original settings, Fina...
	For more complex playback situations, however, you’ll find that Finale’s Instrument List window g...

	MIDI Channels and Patches
	Each MIDI instrument is able to receive MIDI information on one or more of 16 MIDI channels. Some...
	Different sounds within a MIDI instrument have specific numbers assigned to them, called program ...
	To have different programs play back at the same time, you need to use different channels with a ...

	Finale Instruments and Channels
	There are 64 Finale channels available for MIDI. Since each instrument in Finale’s Instrument Lis...
	Finale makes 64 channels available, but each MIDI device only has 16. Using the MIDI Setup dialog...
	Depending on your MIDI setup, you could map four different devices to their own bank of channels,...
	For entering notes with MIDI using HyperScribe, enter any number between 1 and 64 for the Finale ...
	For MIDI playback from Finale, you can either use the Instrument List to assign the channels to s...
	Regardless of whether you use the Instrument List or create expressions, Finale refers to setting...

	Input Device and Output Device
	Input Device and Output Device options in the MIDI Setup dialog box let you choose where you want...
	Note: You can’t assign the same input or output device to more than one bank of Finale channels—a...




