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Chapter 37: Extracting Parts

Extract Parts dialog box
How to get there
Open the document from which you’ll be extracting parts. Choose Extract Parts from the File 
Menu.

What it does
There are three ways to extract parts in Finale (see EXTRACTING PARTS). Of the three, the Extract 
Parts command provides the most flexibility, because it places each extracted part in its own sepa-
rate Finale document that you can view and edit before printing.

In this dialog box, you can specify which parts you want extracted, tell Finale which staves or 
groups to be extracted (so that both staves of a keyboard part will be extracted together, for exam-
ple), and create a basic title for the resultant files, so that you can let Finale perform the part 
extraction unattended.

 This dialog box also provides convenient access to four other dialog boxes, which you can use to 
set up page formatting, page and music spacing options, and define multimeasure rest settings for 
the extracted parts.
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• Staves • Groups. The Staves list contains the name of each staff in the score, and the Group 
list contains the name and number of each group. Use the scroll bar to display all staves in the 
score. Click to select a single staff in the Staves list. Shift-click to select all staves between the 
currently selected staves and the staff you shift-click. Ctrl-click to select an additional single 
staff from anywhere in the list, or ctrl-click a selected staff to remove a single staff from the 
selection. After selecting staves to extract, select any groups you want to extract at the same 
time. Finale will extract each selected staff and group, and create a separate document for the 
extracted part.
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• Music Layout: Fit ___ Measures Per System • Treat Multi-Measure Rests as One Mea-
sure. If you want the same number of measures across each system for the entire piece, select 
this option and enter a number in the text box. Enter the number of measures to spread across 
each staff system in the extracted parts.You may optionally treat multi-measure rests as one 
measure (when checked) or count each measure inside the multi-measure rest individually 
(when unchecked.)

• Music Layout: Space Systems Evenly. Select this option to have Finale space the systems 
evenly across the page in the extracted parts. See SPACE SYSTEMS EVENLY.

• Music Layout: Preserve Current Spacing • Apply Beat Spacing • Apply Note Spacing • 
Apply Time Signature Spacing. Click one of the music spacing options to space and lay out 
each part according to your selection. Choose Preserve Current Spacing to keep the same 
spacing in the extracted parts as currently appears in the score. Choose Apply Beat Spacing to 
position each beat in the measure according to the total duration of its notes. Choose Apply 
Note Spacing to position each note based on its duration. Choose Time Signature Spacing if 
you want Finale to match the measure widths in the extracted part to those in the score, but 
space the beats evenly according to the time signature.For details, see MUSIC SPACING.

• Music Layout: Music Spacing Options. Click this button to display the Music Spacing 
Options dialog box, where you define Finale’s music spacing in detail.

Note: The music spacing options that you specify are the same as those shared by the full 
score; changing them here also changes the options in the full score.

See MUSIC SPACING OPTIONS DIALOG BOX, and MUSIC SPACING for a more detailed discus-
sion of these topics.

• File Names: Generate Names From • Prompt for Each Name • Open Extracted Part. 
Finale needs to know what to call each document it creates for an extracted part. If you want 
Finale to automatically extract parts and create a file name for each document without inter-
vention on your part, select Generate Names From and enter the folder in the text box, fol-
lowed by any variables you would like to use in naming you parts. The variables are detailed 
in the table below.

The default is %f - %s, which using the examples in the table would give you extracted parts 
with file names like “Pastorale-Flute I.mus,” “Pastorale-Piano.mus,” and “Pastorale-
Strings.mus” depending on what parts you selected for extraction.

Variable Represents Example

%f Score file name “Pastorale”

%s Staff name or group name “Flute I” or “Piano” or “Strings”

%i Staff or group number “001”

%n Staff index (score order) “001”

%t Score title from File Info dialog “Symphony No 6” 

%a Abbreviated staff or group name “Flt I” or “Pno”
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Using %n in your file name can help searching and opening files in List boxes. Using %n %s 
would give you “001 Flute.mus,” “002 Oboe.mus,” “003 Clarinet.mus” and so on in the order 
of the score. Thus your files are listed in score order instead of alphabetically according to 
staff or group name. 

If you are using %i Finale will add a G to the files with group numbers to distinguish them 
from staff number files.

Select Prompt for Each Name if you want Finale to ask you for a file name each time a docu-
ment is created.If you check Open Extracted Part, Finale will open the file for each part, lay-
ered on top of each other, when Finale finishes extracting all of the parts. To switch between 
open documents, click on the Window Menu and select the desired file. For more information, 
see the WINDOW MENU.

• Page Format • Multimeasure Rests • Options. Click these buttons to access dialog boxes 
where you define page layout and multimeasure rest settings for the extracted parts. The dia-
log boxes are: Page Format for Parts, Multimeasure Rest, and Page Options.

For more information, see PAGE FORMAT FOR SCORE DIALOG BOX, PAGE FORMAT FOR PARTS 
DIALOG BOX, MULTIMEASURE REST DIALOG BOX and PAGE OPTIONS DIALOG BOX.

• OK • Cancel. Click OK (or press enter) to confirm your parts extraction settings, or click 
Cancel to return to the score without changing any settings.

Page Options dialog box
How to get there
Click the Options button in the Extract Parts dialog box to display the Page Options dialog box.

What it does
In the Page Options dialog box you can specify a page layout for the extracted parts and specify 
certain elements in the full score that you do not want to appear in the extracted part (such as staff 
names or graphics).
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• Staff Placement: New Staff Position • Top Staff • Between Staves. If you want the distance 
between staves and systems to be different in the extracted parts than in the full score, select 
the New Staff Position checkbox, and change the numbers in the Top Staff and Between 
Staves text boxes.

The number in the Top Staff text box sets the distance between each system and the one above 
it. It’s a negative number, because it’s measured down from the bottom line of the system 
above it.

The number in the Between Staves text box sets the distance between staves (if the extracted 
part consists of more than a single staff). It’s also a negative number, because it’s measured 
down from the top line of the staff above it.

• Items to Remove: Single-Page Text Blocks and Graphics (Page 1). This option affects the 
appearance of text blocks and graphics placed as headers and footers. Only page-assigned text 
blocks and graphics displayed on only the first page of the full-score document are affected. 
When selected, the items will not appear in the extracted parts.

• Items to Remove: Single-Page Text Blocks and Graphics (Page 2+). This option affects the 
appearance of text blocks and graphics placed as headers and footers. Only page-assigned text 
blocks and graphics displayed on any single page (except page 1) of the full-score document 
are affected. When selected, the items will not appear in the extracted parts.

• Items to Remove: Staff or Group Names. When selected, Finale hides the staff or group 
names depending on whether you’re currently extracting staff or a group of staves, respec-
tively. When selected, the staff or group name will not appear by the staves in the extracted 
parts.
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• Items to Remove: Multiple-Page Text Blocks and Graphics. This option affects the appear-
ance of text blocks and graphics placed as headers and footers. Only page-assigned text blocks 
and graphics displayed on more than one page of the full-score document are affected. When 
selected, the items will not appear in the extracted parts.

For more information, see TEXT.

• Part Names: Create Staff or Group Name Header. When selected, Finale creates a part 
header using the staff or group names depending on whether you’re currently extracting a staff 
or a group of staves, respectively. 

• Part Names: Set Font. Click this button to go to the Font dialog box where you can select the 
font type, size and style for your staff or group name header.

• Part Names: Resize Name to. Enter a value to resize the text used when displaying the staff 
name, as a percentage of the original text size; for example, you’d enter 50 to halve the text’s 
size.

• Part Names: Page___Through___. Enter the pages on which you want the staff name header 
to appear. Enter zero or leave the Through text box blank to indicate that you want the header 
to appear on the first page specified, through the end of the piece.

• Part Names: H: • V:. These values specify where you want Finale to position the staff name 
header on the first page of each extracted part, relative to the left and top page margins, respec-
tively. The staff name moves to the right as the H: value increases (and to the left as it 
decreases); it moves up as the V: value decreases (that is, it becomes a larger negative value) 
and down as V: increases.

• OK • Cancel. Click OK (or press enter) to confirm the new page layout for the extracted parts. 
Finale will proceed to generate an individual Finale document for each part, according to your 
specifications. Allow plenty of time for Finale to complete the task, especially with large files, 
and make sure there’s room on the hard disk to hold them. Click Cancel to discard any 
changes you’ve made in this dialog box and cancel the part extraction process.

Extracting parts
Finale offers you three ways to extract parts: Turning on Special Part Extraction, to view a partic-
ular part in Page View (while Scroll View still contains the full score); using the Extract Parts 
command, which creates a separate Finale document for each part; and using the Print Parts com-
mand, which causes each part to be printed immediately. Note: if you choose this option you don’t 
have a chance to edit the parts before they print.

When Finale extracts parts, and an instrument doesn’t play for more than one measure, Finale 
groups the silent measures together into a multimeasure rest, or block rest, as shown above. Finale 
automatically breaks up block rests at key or time changes, repeat barlines or text repeats, any 
“real” whole rest (a whole rest you entered, not the default whole rest that appears in any mea-
sures left empty), or any measure you’ve explicitly designated to break such a multimeasure rest. 

[5-11] 7
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See the Break a Multimeasure Rest option, in the MEASURE ATTRIBUTES DIALOG BOX for more 
information.

For a more complete discussion of part extraction, see Installation & Tutorials.

To extract parts into individual documents
If you want to change Finale’s default settings for the shape of multimeasure rests and the type 
style and position of the number that appears over them, see MULTIMEASURE REST DIALOG BOX.

• Save the full score document. 
• Choose Extract Parts from the File Menu. The Extract Parts dialog box appears. Finale will 

prepare to extract parts from the active document.
• Specify the staves and groups you want to extract by highlighting the staff names and 

group names in the Staves and Groups boxes, shift-clicking or ctrl-shift-clicking in the 
list box. Shift click lets you select additional staves. Ctrl-shift-click allows you to select addi-
tional ranges.

• Enter a file name for the resultant documents. If you select the Generate Names From radio 
button Finale proposes the folder then %f - %s. The %f will be replaced by the file name and 
%s will be replaced by the staff or group name of the extracted part. If you want another com-
bination of variable to construct your file name with, see EXTRACT PARTS DIALOG BOX for 
details. If you select the Prompt for Each Name radio button Finale will pause between each 
file to ask you to title the next one. 

• Choose your location to save your documents. Regardless of how file names are generated, 
it is wise not to give your extracted-part files the same name as an existing file in the same 
folder; you won’t be alerted before the older document is replaced by the new one.

• Select the music spacing method that you want applied to the extracted parts, and 
choose your Music Spacing Options. All the types of music spacings available to you with 
the Mass Mover Tool are also available for extracting parts. Choose the method you want for 
the extracted parts. Then, click on the Music Spacing Options button to set details of you 
music spacing including what items to avoid collision of, as well as the width of your mea-
sures (see MUSIC SPACING OPTIONS DIALOG BOX).   See the EXTRACT PARTS DIALOG BOX for 
details on music spacing options. For details on how these spacing commands work, see 
MUSIC SPACING.

• Click the Page Format button to specify the Page Boundaries and Margins, and the Sys-
tem Margins. The Page Format for Parts dialog box appears. The Page Boundary numbers 
define the page size as measured from the bottom left corner. The units are whatever you’ve 
selected using the Measurement Units command (Options Menu). The initial values in this 
dialog box are those that were set in the Page Format for Parts dialog box.
The numbers in the Page Margins boxes define the margins. The System Margins represent the 
distance from the edge of each system to the page margins. See also PAGE LAYOUT.

• Specify the percentage reduction (Page Percentage), and any special formatting for the 
first page and system. If you want to increase the indentation of the first line of music, enter 
a larger value in the First System Indent box; to appear lower on the first page, enter a value 
that’s lower (that is, a larger negative value) in the First System Drop. (You can also lower the 
first page top margin [First Page Drop]; your headers and footers, however, are attached to this 
margin, so if you want to move the music down on the page, do so by increasing the First Sys-
tem Drop.)
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You can also specify the distance between systems (Top Staff) and the distance between the 
staves of each system (Between Staves); check New Distances if you change these numbers. 
When you are done, click OK to return to the Extract Parts dialog box.

• Click the Page Options button to specify any page layout elements you want added to or 
removed from the parts. The Page Options dialog box appears. From here you decide if you 
want the instrument name to appear at the top of each page as a header by selecting Create 
Staff or Group Name Headers you can also specify the position and font settings for this 
name. If you do decide to create a header, you may want to remove the instrument’s name 
from the individual staves. You do so by selecting the Staff or Group Names in the Items to 
Remove section of this dialog box. You can also remove text blocks or graphics assigned to 
page 1 by selecting Single-Page Text Blocks and Graphics (Page 1). Or you can remove text 
blocks or graphics assigned to every other page by selecting Single-Page Text Blocks and 
Graphics (Page 2+). When you are done, click OK to return to the Extract Parts dialog box.

• Click the Multimeasure Rest button to define how you want your multimeasure rests to 
appear in the extracted parts. See the MULTIMEASURE REST DIALOG BOX for more details.

• Click OK (or press enter). Finale will generate an individual Finale document for each part, 
according to your specifications. Allow plenty of time for Finale to complete the task, espe-
cially with large files, and make sure there’s room on the hard disk to hold these files.

To break a multimeasure rest
See MEASURE ATTRIBUTES DIALOG BOX–Break a Multimeasure Rest.

To print extracted parts directly from the score
This option is fast and simple, but it does not offer you the flexibility of extracting parts to sepa-
rate documents. The measure widths in the score are the measure widths you’ll get in each 
extracted part, making it useful for pieces in which the measures have a uniform width.

• Choose Print Parts from the File Menu. The Print Parts dialog box appears.

• Click Format Parts. The Format Parts dialog box appears. From here, you can define your 
page setup to be used for the printed parts.

• Click Multimeasure Rest. The Multimeasure Rest dialog box appears. Define how you want 
your multimeasure rests to appear in the printed parts.

• Click OK (or press enter) twice. You return to the Print Parts dialog box.

• Click OK (or press enter). The printing dialogs box appears as usual, and Finale proceeds to 
print the parts, one by one.

To temporarily view an “extracted” part (without deleting all other parts in a 
score) using Special Part Extraction

• Click the Staff Tool s. Click the part you want to view as an “extracted” part. If 

you’re extracting a piano part, you can highlight both staves’ handles by shift-clicking the 
staves, or by drag-enclosing their handles. Note that you need to select the staff handle on the 
staff lines, not the staff name handle.
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• Choose Special Part Extraction from the Edit Menu. The MULTIMEASURE REST DIALOG 
BOX appears.

• Set the position for the multimeasure rest number. Set the position of this number by enter-
ing a value in the H: and V: text boxes. The units are whatever you specified using the Mea-
surement Units command, located in the Options Menu.

• Click OK (or press enter). 

• Choose Page View from the View Menu. Page View now contains only the extracted part(s), 
which you can edit as desired. It’s useful to note that this “extracted” part is still part of the full 
score; correct a note in one view, and you correct it in the other.

If you later change your mind about any of the settings you made—the rest shape or the posi-
tion of the number, or you want to see your whole score—choose Special Part Extraction 
again from the Edit Menu to turn it off. The whole score will then reappear in Page View.

Note, items are not updated in page view if they are added to measures containing a multime-
asure rest. If you add notes to an empty measure in Scroll View, Finale won’t break up an 
existing multimeasure rest in Page View to update the multimeasure rest. If you want your part 
updated, deselect Special part extraction from the Edit Menu, and go through these steps 
again. See also, MEASURE ATTRIBUTES DIALOG BOX–Break a Multimeasure Rest for informa-
tion on breaking a multimeasure rest.

On the other hand, keep in mind changes you make to the layout for the “extracted” part will 
also affect the full score.

• Choose Print from the File Menu, and print as usual. For a more complete discussion of 
Special Part Extraction, see Installation & Tutorials.

•


	Chapter 37: Extracting Parts
	Extract Parts dialog box
	How to get there
	What it does

	Page Options dialog box
	How to get there
	What it does

	Extracting parts
	To extract parts into individual documents
	To break a multimeasure rest
	To print extracted parts directly from the score
	To temporarily view an “extracted” part (without deleting all other parts in a score) using Speci...



