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Chapter 3: Edit Menu
Edit Menu
How to get there
The Edit Menu is one of Finale’s six unchanging menus.

What it does
You can find an assortment of editing commands in the Edit Menu. Use the Edit Menu to cut, 
copy and paste text when you’re editing the actual text (these commands are also available in the 
Mass Mover and Text Tools). You can also import and export MIDI data back and forth between 
Finale and any other application that supports the transfer of MIDI information via the clipboard. 
(See MIDI FILES)
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When you copy or paste files into the clipboard, the Cut, Copy, Insert and Paste/Replace Entries 
commands in the Edit Menu change to reflect the action that will occur, depending on whether a 
modifier key is held down, and which key is used.
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Edit Menu commands:

If you press shift, then choose Import MIDI from Clipboard from the Edit Menu, Finale removes 
the ellipses (…) from the command, indicating that Finale will transcribe the MIDI data without 
showing the Import MIDI Data from Clipboard dialog box—though it still uses the settings from 
the dialog box. See IMPORT MIDI DATA FROM CLIPBOARD DIALOG BOX and MIDI FILES for 
details.

• Undo. All Finale’s document settings can be restored to their previous settings with the 
“undo” command. After you change a dialog box that contains document settings and click 
OK to return to the score, you can choose Undo from the Edit Menu to return to the previous 
settings. You can also use the Edit Menu Toolbar icon to undo any action. Data Check actions 
are also undoable when you return to the score.

You can undo the settings in all dialog boxes in the Options Menu’s Document Settings sub-
menu, and in dialog boxes associated with the tools that contain document settings. These dia-
log boxes include: the Default Tuplet Visual Definition (Tuplet Tool); and all dialog boxes 
associated with the Smart Shape Menu (Smart Shape Tool).

As you edit a file, Finale automatically saves your operations so they can be quickly reversed 
if you choose Undo from the Edit Menu. However, you might occasionally run low on disk 
space while you’re working in Finale. A quick way to recover space without exiting Finale is 
to toggle Undo off and on in the PROGRAM OPTIONS DIALOG BOX. This causes Finale to delete 
and recreate the “undo” files it’s currently maintaining, which frees up space on your hard 
disk. These files will always be automatically deleted when you exit Finale. See UNDO.

• Redo. Choose Redo perform the previous undo action. You can also use the Edit Menu Tool-
bar icon to redo any action. If you have performed too many undo actions in a row, use the 
redo to replace the actions removed. See UNDO.

• Undo/Redo Lists. Choose Undo/Redo Lists to display the Undo/Redo Lists dialog box with a 
list of your past actions. You can also use the Edit Menu Toolbar icon to show this list of 
actions. You may select a point in this list in which to undo or redo your actions. See UNDO/
REDO LISTS DIALOG BOX and UNDO.

• Cut. After selecting a region of music with the Mass Mover Tool, choose Cut to place the 
selected music on the Clipboard and simultaneously remove the music from the score. (Finale 
asks you if you want to remove only the music, leaving behind rests, or if you want to remove 
the selected beats or measures entirely.) Once you’ve placed the cut music on the Clipboard, 
you can paste it to another place in your score or into another Finale document. You can also 
use the Edit Menu Toolbar icon to Cut to the Clipboard.

No 
modifier

shift ctrl ctrl-shift

Cut Cut and Filter Cut to Clip File Cut and Filter to Clip File

Copy Copy and Filter Copy to Clip File Copy and Filter to Clip File

Insert Insert Insert from Clip File Insert from Clip File

Replace Entries Replace Entries Paste from Clip File Paste from Clip File
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If you like, you can save the cut material into a separate file, called a Clip File, which you can 
later access for pasting into another document. Press ctrl while choosing Cut; Finale will ask 
you to give the Clip File a name. In this way, you can create an assortment of musical seg-
ments or motifs, each of which you can access with the Insert or Paste commands to paste 
them into other documents. 

If you press shift while choosing Cut, Finale will display the Items to Clip dialog box, which 
gives you the option of excluding some of the score elements—lyrics or expression marks, for 
example—from the cut material. (If you press both ctrl and shift when you choose Cut, Finale 
will display the Items to Clip dialog box and place the cut material into a Clip File.) See ITEMS 
TO CLIP DIALOG BOX.

You can also place cut text on the Clipboard in Finale’s Edit Lyrics or Edit Text windows, as 
well as access the menu itself in either of these windows.

• Copy. After selecting a region of music with the Mass Mover Tool, choose Copy to place a 
duplicate of the selected music on the Clipboard; you are now ready to paste to another place 
in your score or another Finale document. (You can’t paste copied Finale music into another 
program, however; see GRAPHICS TOOL for instructions on transferring music graphics.) You 
can also use the Edit Menu Toolbar icon to Copy to the Clipboard.

As with the Cut command, you can press ctrl while choosing Copy to save the copied material 
into a separate Clip File, which you can later access for pasting into another document. Finale 
will ask you to give the Clip File a title. In this way, you can create an assortment of musical 
segments or motifs, each of which you can access with the Insert or Paste commands to paste 
them into other documents.

If you press shift while choosing Copy, Finale will display the Items to Clip dialog box, which 
gives you the option of excluding some of the score elements—lyrics or expression marks, for 
example—from the copied material. (If you press both ctrl and shift when you choose Copy, 
Finale will display the Items to Clip dialog box and place the copied material into a Clip File.) 

You can also place copied text on the Clipboard from Finale’s Edit Lyrics or Edit Text win-
dows, as well as access the menu itself in either of these windows.

• Insert. Choose Insert if you want to insert whatever music you’ve cut or copied to the Clip-
board between two existing beats or measures. First tell Finale where you want the material 
inserted by selecting any amount of music just after the desired point of insertion. See COPY-

ING MUSIC for an illustration.

• Paste (Replace Entries). (Replace Entries only appears when the Mass Mover Tool is 
selected.) Choose Paste if you want whatever music you’ve cut or copied to the Clipboard to 
paste over (replace) the music in the target document (first use the Mass Mover to select the 
area of music you want to replace). You can also use the Edit Menu Toolbar icon to Paste from 
the Clipboard. See COPYING MUSIC for an illustration.

• Export MIDI to Clipboard. This command provides a quick way to transfer MIDI informa-
tion to sequencing programs, such as Cakewalk, that support MIDI information on the clip-
board. When you’re ready to export your MIDI information, select the region that you want to 
export using the Mass Mover Tool or other tool with regional selection, then choose Export 
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MIDI to Clipboard. Finale copies the MIDI information from the selected region on to the 
clipboard. You can then paste or import the MIDI information into another program.

• Import MIDI from Clipboard. This command provides a way to import MIDI information 
from sequencing programs. Once you have recorded your performance or created the MIDI 
information (such as controller data) in a sequencing or other MIDI program that supports 
MIDI information in the clipboard, copy it into the clipboard. Switch to Finale, click the Mass 
Mover Tool or any other tool with regional selection, select the measures into which you want 
to paste the information, then choose Import MIDI from Clipboard. The Import MIDI Data 
from Clipboard dialog box appears. If necessary, change the quantization settings for the 
notated music, then click OK. The notated music appears. For more information about the 
workings of the Import MIDI Data from Clipboard dialog box, see IMPORT MIDI DATA FROM 
CLIPBOARD DIALOG BOX.

This command can be especially useful when you’re creating playback effects such as pitch 
bend, pan, or volume control. For example, you could create a crescendo on an empty track in 
your sequencer, then import it into Finale. As long as the copied sequencer information does 
not contain MIDI note data, Finale preserves its existing notes and pastes only the copied 
information into the measures. If the copied sequencer information contains MIDI note data, 
Finale transcribes new notes.

Note: Press shift when choosing this command to use the current settings in the Import MIDI 
Data from Clipboard dialog box (without displaying the dialog box on the screen).

• Select All. You can use this command with most of Finale’s tools. In a number of cases, you 
can exclude (deselect) one handle at a time from the selection by shift-clicking its handle. 

• Select Partial Measures. When this command is checked, you can select part of a measure or 
measures in the Mass Mover Tool and the Staff Tool. When it’s unchecked, you select music 
in complete one-measure increments. You can drag-copy, use the Edit commands (and create 
Clip files) with partial measures. Note, however, that if you select a partial measure region 
with the Mass Mover Tool, only the notes, rests, and their related items (such as articulations) 
are affected. Measure items (such as measure attached expressions) are not included when 
either the source or the destination is a partial measure region.

• Select Region.When you choose this command, the Select Region dialog box appears, in 
which you can enter the staff names, beat and measure numbers that define the region you 
want to select. When you click OK, Finale selects the region you’ve specified—even if none 
of it is visible on the screen. See SELECT REGION DIALOG BOX for further details.

• Special Part Extraction. This command provides access to one of Finale’s three part-extrac-
tion methods. Using Special Part Extraction, you can see the full score in Scroll View while 
the extracted part appears, ready for editing and printing, in Page View. A full tutorial for the 
Special Part Extraction command appears under EXTRACTING PARTS.

Before the Special Part Extraction command will work, you must be in Scroll View, then 
select a staff (or staves) by clicking the Staff Tool and then selecting their handles. When you 
choose Special Part Extraction, a dialog box appears, letting you select the multimeasure 
(block) rest shape you want to use. (See MULTIMEASURE REST DIALOG BOX.) After you’ve 
made your settings, click OK. You return to the score.
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At first you won’t notice anything different, however, if you look at the Edit Menu, you’ll see 
a check mark beside Special Part Extraction, telling you that Page View now contains the 
extracted part. Choose Page View from the View Menu to examine and edit the extracted part.

To exit Special Part Extraction mode (and return to viewing the full score in Page View), 
choose Special Part Extraction again from the Edit Menu.

• Update Layout. To speed up its operations, Finale doesn’t constantly recalculate the position-
ing and page layout of measures within your score. Instead, this recalculation only takes place 
when you request it by choosing Update Layout from the Edit Menu, unless you’ve turned on 
Automatic Update Layout below.

If you enter Page View without choosing Update Layout, you may discover strange measure 
spacing if you’ve made any changes to the widths of measures (by using, for example, the 
Resize Tool, the Music Spacing commands, the Page Layout Tool, or the Measure Tool). Any 
of these actions can result in very wide or very cramped measures, or duplicated or missing 
systems on each page. By choosing Update Layout, you tell Finale to lay the measures out 
again within each system, taking such changes into account, in order to create attractive, 
neatly justified systems with appropriate measure spacing.

To further save you time, when you’re in Page View, Finale only readjusts the measure layout 
from the page you’re viewing to the end of the document. In other words, if you’re satisfied 
with the layout of the first five pages, you don’t have to wait for Finale to readjust them; scroll 
to page six before choosing Update Layout. (Update Layout affects the entire piece if you’re 
viewing page one, or if you’re in Scroll View.)

Update Layout performs another useful function. One way to manually arrange measures on 
the page is to use Finale’s measure group features (such as the Fit Music command in the Page 
Layout Menu and the Mass Mover Menu, or the Mass Mover up/down arrow trick). For details 
on these techniques, see MEASURE LAYOUT. If you ever want to delete such measure groups 
(and restore all measures to their original “floating” status), press shift while selecting Update 
Layout from the menu.

When you choose Update Layout from the Edit Menu, Finale uses the settings in the Update 
Layout Options dialog box (found in the Options Menu) to determine what parts of the music 
layout it will recalculate to catch small changes in positioning and page layout. See UPDATE 
LAYOUT OPTIONS DIALOG BOX.You can press shift before choosing this command to remove 
any forced measure groupings in the score.

• Automatic Update Layout. This option has no effect in Scroll View. In Page View, this option 
determines whether Finale will update the layout each time it redraws the screen. When this 
option is selected, Finale will update the layout each time it redraws the screen (it will take a 
little extra time to perform the additional task). Finale actually updates the layout for the cur-
rent page and discards the layout for all subsequent pages, although it doesn’t take the time to 
update the layout until you display the subsequent pages. When Automatic Update Layout is 
not selected, Finale will still, on occasion, update the layout. For instance, if you adjust the 
position of a staff or add staves to the score, Finale will update the layout.
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• Automatic Music Spacing. Select this option to have your music automatically spaced as you 
enter it—at the end of a Speedy Entry measure, at the end of a HyperScribe session, or after 
each note in Simple Entry. The music spacing applied is based on the currently loaded spacing 
width library. See MUSIC SPACING for more details.

• Snap to Grid • Snap to Guides. Choose these menu items to invoke the capability to move 
any item to the nearest guideline or grid point. See GRID/GUIDE OPTIONS DIALOG BOX for 
more information on setting up grids and guides. See SNAPPING TO GRIDS AND GUIDES for 
details on how to use this feature.
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Undo/Redo Lists dialog box
How to get there
Choose Undo/Redo Lists from the Edit Menu.

What it does
Choosing Undo/Redo Lists displays the Undo/Redo Lists dialog box from which you can select a 
point in the list of past actions in which to undo all the actions down to and including that point or 
redo all the actions up to and including a specified point.

• Select Edit(s) to Undo. Click on an action in this list to undo all the actions down to and 
including that action.

• Select Edit(s) to Redo. Click on an action in this list to redo all the actions up to and includ-
ing that action.

• OK • Cancel. Click OK to perform the undo or redo, or Cancel to return to the score.
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Import MIDI Data from Clipboard dialog 
box
How to get there
Place some MIDI data on the clipboard (from Finale or another sequencing program). Click the 

Mass Mover Tool l or any other tool with regional selection. Select a region of music. Choose 

Import MIDI from Clipboard from the Edit Menu.

What it does
Use the Import MIDI Data from Clipboard dialog box to change quantization settings and other 
options when you’re importing a MIDI file from the clipboard. The options are the same as those 
in the Import MIDI File dialog box, except Convert Markers is not available. For an explanation 
of these settings, see IMPORT MIDI FILE OPTIONS DIALOG BOX and QUANTIZATION SETTINGS DIA-

LOG BOX.

To use the current settings in the Import MIDI Data from Clipboard dialog box (without display-
ing the dialog box on the screen), press shift when you choose Import MIDI from Clipboard from 
the Edit Menu.
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Select Region dialog box
How to get there
Choose Select Region from the Edit Menu. (Used with the Mass Mover Tool, Staff Tool, Measure 
Tool and MIDI Tool.)

What it does
When you want to select a region of measures to edit, erase, or copy, you normally click to select 
one measure, shift-click to select additional measures, drag-enclose to select several on-screen 
measures, click to the left of the staff to select the entire staff, or choose Select All from the Edit 
Menu to select the entire document. 

However, many of these methods require that the measures you’re selecting be visible on the 
screen. With this dialog box, however, you can select large or small sections of your score without 
scrolling; in fact, if you’re viewing measure 200, you can even select measures 1 through 10 
remotely (without actually clicking any measures) from this dialog box. Finale will select the 
specified measures, even if you can’t see them. This dialog box even lets you select a certain range 
of beats within the measures.

• From Staff: ___ • Measure: ___ • Beat. Using these controls, specify the staff name and measure 
number, respectively, of the first measure of the region you want selected. Choose the staff name 
from the drop-down list, and type a number into the Measure text box.

If you select any measures before you choose Select Region from the Edit Menu, Finale iden-
tifies the first selected measure’s number and staff name in these boxes automatically. That’s 
useful to remember if the first measure of the desired region is visible on the screen—then, 
when you arrive at this dialog box, you only have to specify the ending measure of the region 
(see below), which saves you several steps.
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With the beat selection you can specify which beat in the measure you want to begin the selec-
tion. Type it into the text box at the right side of the dialog box. For example, if the fourth beat 
of the measure is supposed to begin the selected region, type a 4 into the box. Alternatively, 
you can choose EDUs from this drop-down list, and enter an EDU value (1024 per quarter 
note) to specify a starting point with high precision. If you select a beat, Finale will put a 
checkmark next to Select Partial Measures in the Edit Menu to show it has been enabled.

• Through Staff: ___ • Measure: ___ • Beat. Using these controls, specify the staff name and mea-
sure number, respectively, of the last measure of the region you want selected. Choose the staff name 
from the drop-down list, and type a number into the Measure text box.

Again, if you select any measures before you choose Select Region from the Edit Menu, 
Finale enters the last selected measure’s number and staff name (or number) in these boxes 
automatically. That’s useful to remember if the last measure of the desired region is visible on 
the screen—then, when you arrive at this dialog box, you only have to specify the beginning 
measure of the region (see above).

And here, too, you can also specify which beat in the measure you want to end the selection 
by typing a beat number into the text box at the right side of the dialog box. Alternatively, you 
can choose EDUs from this drop-down list, and enter an EDU value (1024 per quarter note) to 
specify an ending point. If you select a beat, Finale will put a checkmark next to Select Partial 
Measures in the Edit Menu to show it has been enabled.

• OK • Cancel. Click OK (or press enter) to return to the score, where Finale selects (high-
lights) the measures in the region you specified. Click Cancel to return to the score without 
selecting any measures.

Copying music
This entry outlines some general techniques for copying music from one place to another with the 

Mass Mover Tool l. For instructions on copying specific elements of music, see also CHORD 

SYMBOLS; LYRICS; and ARTICULATIONS. See also MIRRORING, which shows you how to create 
“intelligent” copies that remain dynamically linked to their source music.

When you copy music as described here, keep in mind the important difference between inserting 
music and replacing it. If Copy and Replace is selected in the Mass Mover Menu, then drag-copy-
ing or pasting pastes over what was already there. If Copy and Insert is selected, the new material 
is inserted at the location of the cursor (or, if you’re pasting from the clipboard, just before the 
selected region). 

If Select Partial Measures is selected in the Edit Menu, then Copy and Insert has an important sec-
ondary effect. Since you’re inserting extra beats into a previously full measure, Finale will auto-
matically rebar the subsequent music—in other words, redistribute notes through the measures of 
your score until every measure contains the correct number of beats. (You dictate its behavior in 
this regard by choosing Rebar Options from the Rebar submenu of the Mass Mover Menu, and 
making the appropriate settings.)
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Another important distinction can be made between using the clipboard (Edit Menu) and drag-
ging. For some materials, such as lyrics and measure expressions, you may prefer the drag 
method. When you use the clipboard for copying lyrics, Finale doesn’t know if you’re pasting 
back into the same document. To avoid overwriting lyrics, the pasted lyrics are placed into another 
verse. When you use the drag method, lyrics remain in the same verse, but are also dynamically 
linked. When you use the clipboard for copying measure expressions, the Show On choices are 
reset to All Staves. To retain your Staff List or Show This Staff Only, use the drag method.

To specify what, and how, you want to copy
One of Finale’s many useful features is that it lets you copy only selected elements of music—
such as chord symbols or articulations—without affecting the notes themselves.

• Click the Mass Mover Tool l. The Mass Mover Menu appears.

• Choose the elements you want to copy from the Mass Mover Menu. If you want to copy 
everything—music, lyrics, measure widths, expression marks, and all—make sure Copy 
Everything is checked in the Mass Mover Menu. 

Otherwise, choose Copy Entry Items (markings, lyrics, chord symbols, and other information 
associated with individual notes) and/or Copy Measure Items (measure-related elements like 
key signatures, Smart Shape slurs, and so on).

• Specify either Copy and Replace or Copy and Insert from the Mass Mover Menu. The 
first command means that anything you copy will wipe out, or replace, any music in the target 
measures. The second means that the copied material will be placed in front of any existing 
music, pushing it to the right if necessary.

Of course, it doesn’t make much sense to “insert” articulation marks (for example) in front of 
other marks; therefore, if you used the Copy Entry Items command to select only note-
attached elements (such as articulations or chord symbols) but not the notes themselves, 
Finale will tell you that you’ve specified an impossibility. Choose Copy and Replace instead, 
and try again.

• Select a region. Click or drag-enclose any region of music to select it. Add additional mea-
sures to the selection by shift-clicking, select an entire staff by clicking to the left of it, or 
choose Select All from the Edit Menu. 

If Select Partial Measures is checked in the Edit Menu, select any region, large or small, by 
drag-enclosing it. Double-click to select a full measure, and double-click a second time if you 
want to include all other staves in your selection.

To copy to another place in the document (by dragging)
• Select the music to be copied. See “To specify what, and how, you want to copy,” above.

• Drag the source music so that it’s superimposed on the first target measure. If the first 
target measure is not on-screen, scroll until you see it. Then, while pressing ctrl and shift 
together, click the first target measure.
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When Select Partial Measures is selected (Edit Menu), Finale replaces whatever was in the 
target measures, starting at the position of the cursor, with a copy of the music you originally 
selected. In other words, if you drag to beat three of a certain measure, the selected music will 
begin at beat three. If the measure is empty, the music will appear at the nearest beat following 
the cursor.

When copying full measures, the COPY MEASURES DIALOG BOX appears (unless you’re copy-
ing to a target measure directly above or below the source measure.)

• Type the number of times you want the material (horizontally) copied. Click OK (or 
press enter). Finale replaces whatever was in the target measures with a copy (or copies) of 
the music you originally selected. If you specified that you wanted to copy only certain note-
related items (like markings or chord symbols), they are copied only where the target region 
contains notes or rests that fall on the same beats as in the original selection. (It wouldn’t make 
much sense to put a staccato mark over a whole rest, for example.)

If you specified that you wanted to insert the copied notes, and Select Partial Measures is 
selected in the Edit Menu, Finale will rebar the piece to accommodate the extra beats.

To copy and paste
• Select the music to be copied. See “To specify what, and how, you want to copy,” above.

• Choose Copy from the Edit Menu. The selected music is placed on the Clipboard. At this 
point, you can paste the copied material anywhere—either elsewhere in the same document, 
or into another document. If you want to paste to another document, open the document now, 
using the Open command in the File Menu. You can’t, however, directly paste music into other 
programs such as word processing or graphics programs. For details on exporting music into 
another program, see ENCAPSULATED POSTSCRIPT (EPS) and GRAPHICS TOOL.

• To insert the copied music into existing music, select the music just after the desired 
insertion point. Choose Insert from the Edit Menu. There’s an important distinction 
between Finale’s two paste commands, Insert and Paste. The first one, Insert, introduces new 
beats and measures into the piece, pushing all existing music to the right. You indicate where 
you want the copied material to appear by selecting the notes or measures just after it. So, if 
you want the copied music to appear between measures 3 and 4, click measure 4. (See the fig-
ure below.)

When it adds new measures to the piece, Finale never misaligns one staff’s music with 
another’s. Therefore, if the material you copied was from only one staff, but you’re pasting 
into a many-staved score, the music on all the other staves will be shifted to the right (and 
empty measures added), even though you’re only inserting into one staff. 

Suppose you’ve copied two measures onto the Clipboard. And you highlight two measures of a 
blank staff. If you choose Insert instead of Paste (Replace Entries),
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the Clipboard material will be inserted in front of the existing music. The music in other staves gets 
pushed to the right. (In this example, Select Partial Measures has been turned off in the Mass Mover 
Menu.)

If the music on the Clipboard was copied from (for example) ten staves, you don’t have to 
insert all ten staves’ worth into the target staff. You can highlight a single measure in only four 
staves of the target piece (a “slice” of the score that’s four staves tall); only the first four staves 
of the copied material will be inserted, and Finale will ignore the remaining material on the 
Clipboard. (As before, however, all other staves in the target document will also be shifted to 
the right, so that the existing music doesn’t get misaligned.) On the other hand, if you do want 
the entire copied section to be inserted, be sure to select a measure in the target region at least 
as many staves “deep” as the copied region.

• If you want the copied music to paste over (replace) the music in the target document, 
select the region of music you want to replace. Finale’s second paste command, Paste 
(Replace Entries), doesn’t introduce any new measures into the “target” document; instead, it 
replaces whatever was there with the contents of the Clipboard.

Once again, the “target” region doesn’t have to be as large as the original copied section; 
Finale only replaces the music that you highlight in the target document. In other words, if the 
copied material is ten measures long, you don’t have to paste over ten measures in the target 
staff. You can select only six measures; they’ll be replaced by the first six measures of the cop-
ied material (and Finale will ignore the remaining four measures). Therefore, if you do want 
the entire copied section to be pasted, be sure to select a region as large as the copied region.

• Choose Replace Entries from the Edit Menu. The command is called Replace Entries 
(notes and rests) because it doesn’t wipe out any measure-related musical information, such as 
rehearsal marks (measure attached expressions) and measure-width information. Only notes, 
musical elements attached to them, and Smart Shapes are replaced. 
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To make a copy of a document
These instructions assume that you’re running Finale. To duplicate a Finale document when 
you’re not in Finale, select the desired file using Explorer and choose Copy from the File menu. 

• Open the document. Choose Save As from the File Menu. A dialog box appears, allowing 
you to name the copy. No two documents in the same folder may have exactly the same name.

• Click Save. The copy of the document is left on the screen, and the original is automatically 
closed without saving any changes.

To copy multiple passages of music to another document (using Clip Files)
Finale’s Clip Files feature gives you, in effect, multiple Clipboards, each containing a different 
passage of music. By making Clip Files, you can copy many sections from a single document 
before pasting them, one by one, into a new document. These files are stored on your hard 
disk, where you can easily retrieve them for use in any document—a handy feature when you 
want to re-use motifs.

• Select the music to be copied. See “To specify what, and how, you want to copy,” above.

• While pressing ctrl, choose Copy from the Edit Menu. When you ctrl-Copy in this way, 
you tell Finale to place the copied material into a file of its own, called a Clip File, instead of 
on the invisible Clipboard. 

A dialog box appears, asking you to name your Clipboard File. 

• Name the Clip File, and click Save (or press enter). Repeat the process with as many other 
sections as you want: select the region, choose Copy while pressing ctrl, name and save the 
Clip File.

• Choose Open from the File Menu, and select the target document (if it’s not already 
open). 

• If you want to insert the copied music between two existing measures, click the measure 
just after the insertion point. While pressing ctrl, choose Insert from the Edit Menu. 
Once again, the ctrl key tells Finale you intend to access a Clip File. When you choose Insert, 
the Paste dialog box appears, displaying the names of the Clip Files you’ve created. Double-
click the name of the desired Clip File. 

If the material you copied was from only one staff, but you’re pasting into a many-staved 
score, the music on all the other staves will be shifted to the right (and empty measures 
added), even though you’re only inserting into one staff. See “To copy and paste,” above, for 
details.

• If you want the copied music to paste over (replace) the music in the target document, 
select the region of measures whose music you want to replace. The copied material will 
only replace the selected region, even if all of it doesn’t get pasted. Therefore, if you do want 
the entire copied section to be pasted, be sure to select a region as large as the copied region. 
Again, see “To copy and paste” above, for details. 

• While pressing ctrl, choose Replace Entries from the Edit Menu. A list box appears, dis-
playing the names of the Clip Files you’ve created. Double-click the name of the desired Clip 
File. (As before, only notes, musical elements attached to them, and Smart Shapes are 
replaced.)
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To combine two files
Because copying between files requires using the clipboard, you should be aware of some unique 
aspects of clipboard copying in Finale. When you use the clipboard for copying lyrics, Finale tries 
to avoid overwriting lyrics by placing the pasted lyrics into another verse. You can either drag the 
verse positioning triangle up or copy and paste the lyrics into the appropriate verse. See LYRICS. 
When you use the clipboard for copying measure expressions, the Show On choices are reset to 
All Staves. See EXPRESSIONS.

• Open the file you want to add music to. This is now your TARGET document. You may 
wish to save a backup version of the file.

• Click the Measure Tool z. From the Measure Menu, choose Add.

• Open the file you want to copy music from. This is now your SOURCE document. You may 
wish to save a backup version of the file.

• In your source document, click the Mass Mover Tool l. The Mass Mover Menu 

appears.

• From the Mass Mover Menu, choose Copy and Insert. From the Mass Mover Menu, 
choose Copy Everything.

• From the Edit Menu, choose Select All. All of your music should be highlighted.

• From the Edit Menu, choose Copy.

• From the Window Menu, choose your target document. Your target document moves to the 
front as the active window.

• Click on the last empty measure to select it.

• From the Edit Menu, choose Insert. Your source document has now been added to the end of 
your target document.

• Click on the last empty measure to select it and hit Delete.

To copy score markings based on a rhythmic match

• Click the Mass Mover Tool l. The Mass Mover Menu appears.

• Select a region. Click or drag-enclose any region of music to select it. Add additional mea-
sures to the selection by shift-clicking. If Select Partial Measures is checked in the Edit Menu, 
select any region, large or small, by drag-enclosing it. Double-click to select a full measure, 
and double-click a second time if you want to include all other staves in your selection.

The selection must occur on a single staff, not spanning multiple staves. Only rhythms and 
markings in the current layer of the source region are used for the pattern matching and paint-
ing process.

• From the Mass Mover Menu, choose Set SmartFind Source Region. A outline box appears 
around the selected region. If you selected the wrong region, choose Deselect SmartFind 
Source Region from the Mass Mover Menu, and try again.
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• Optional: select a target region to paint. If no region is selected, SmartFind will assume you 
wish to scan the entire score. You may include partial measures in your target region.

• From the Mass Mover Menu, choose Apply SmartFind and Paint. The SmartFind and 
Paint dialog box appears. See SMARTFIND AND PAINT DIALOG BOX.

• Check the box for the markings you want to copy. If you’ve already entered some markings 
into your score, you may wish to check “Delete Target Markings Before Paint.” With this box 
checked, SmartFind will erase the markings before painting the new markings, so you get an 
exact duplicate. Note that checking this option will only erase markings checked to paint. For 
example, if all markings to paint were checked except articulations, SmartFind would erase 
markings in the target but leave articulations untouched. The checked marking types will be 
deleted regardless of whether the markings appear in the source region.

• Click Find. SmartFind shows you the first match, if any. SmartFind will look for matches in 
all layers of the target region, regardless of the source layer. SmartFind will search the first 
measure of the top staff selected to the last measure of the top staff in the region, then continue 
through layers, then down through the rest of the staves. SmartFind will search for a match 
based on the rhythmic or note durations and therefore will consider tied notes. SmartFind will 
ignore grace notes, Voice 2 and mirrored notes.

• Click Paint to apply the markings to the match, or Paint All to apply the markings to all 
matches, or click Find Next to skip this match. SmartFind copies the select score markings 
from the source region onto the rhythmic match target region. Only the first note of a tied note 
will receive copied markings.

• When you’re finished, click Cancel or Close. You return to the score.

Selecting music
You select regions of music using the Mass Mover Tool, although many of the instructions here 
also apply to the Staff Tool, Measure Tool, MIDI Tool, the Note Mover Tool and the Lyrics Tool’s 
Clone Lyric command.

You can select any region of music, regardless of whether or not it’s an increment of one measure. 
To use this feature, choose Select Partial Measures in the Mass Mover Menu, so that a checkmark 
appears. (If you prefer the old scheme, leave Select Partial Measures off).

To select the entire document
• From the Edit Menu, choose Select All (or press ctrl-A). 

To select an entire staff
• Click to the left of the staff. To select additional staves, shift-click to the left of them. (You 

can’t select staves out of order.)

To select part of a measure
• From the Edit Menu, choose Select Partial Measures, unless a checkmark already 

appears. Finale remembers the status of the Select Partial Measures option with each docu-
ment. If you want this setting to be turned on in every new document you create, be sure that 
it’s on in your Maestro Font Default file.
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• Drag diagonally across any part of a measure. It’s OK to drag past a barline and into 
another measure, too. You can shift-click to extend the selection to another part of the score, 
exactly as you would when Select Partial Measures isn’t on. 

When you select a partial measure, Finale highlights an area from the left edge of the first 
selected note to the right edge of the space after the last selected note, to help reinforce the fact 
that you’re actually selecting a stretch of musical time.

Almost every Finale mass editing command may be applied to partially-selected measures. A 
few, however, don’t make sense unless applied to full measures, such as – Add, Insert, or 
Delete Measures, Change submenu: Key, Time; Utilities submenu: Check Ties, Convert Mir-
rors, Explode Music, Implode Music; Music Spacing submenu: Apply Beat Spacing, Apply 
Note Spacing, Apply Time Signature Spacing; Fit Music; Move Layers. 

You can apply all other Mass Mover Menu commands—including Transpose, Rebeam, and 
Rebar—to partial-measure selections. You can use the Edit Menu commands, too, such as Cut, 
Copy, and Insert. Note, however, that when partial measures are selected, the Edit commands 
only cut, copy, or paste note-related items (notes, lyrics, chord symbols, and so on), but not 
measure-related items (like rehearsal marks, key changes, and so on).

If you try to use a full-measure–only command after selecting only part of a measure, Finale 
will let you know; you’ll have the choice of canceling the command, or applying the com-
mand to all measures that are even partly selected.

To select a full measure
• If there’s a checkmark beside Select Partial Measures (in the Edit Menu), double-click a 

measure. If Select Partial Measures is turned off, you can select a measure by clicking it once. 

To select additional measures, assume that the one you just selected is the first one in the 
selection; shift-click a later (or earlier) measure to select it and all measures in between.

To select a full measure stack
A measure stack is one measure as played by all the instruments in the staff—in other words, a 
one-measure vertical slice of a score. (Generally, the term measure in this manual refers to one 
measure of one staff.)

• If Select Partial Measures is selected (in the Edit Menu), double-click a measure (to 
select the full measure); then double-click a second time. If Select Partial Measures is not 
selected, you select a measure stack by double-clicking a measure.

To select a large region without scrolling
• From the Edit Menu, choose Select Region. The Select Region dialog box appears.

• Enter the staff, measure, and beat with which you want to begin and end the selection. 
For example, you can select the Flute staff, measure 4 beat 2, through the Bass staff, measure 
10 beat 1. See SELECT REGION DIALOG BOX for more information. The important thing to 
remember is that this feature lets you select music without having to scroll to it (and wait for 
the screen to redraw). You can even select music that’s not on the screen.

• Click OK (or press enter). 
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To select all measures right or left of a selection
• Select the measure or partial measure.

• Hold down the shift key and the left or right arrow key. Finale selects all measures to the 
left or right of your original selection.

Major seconds (in different voices and layers)
When notes in two Finale layers fall on the same beat but are a major second apart, Finale usually 
automatically offset some of them to avoid overlapping the noteheads. However, if you’ve turned 
off Automatic Music Spacing, Finale won’t adjust these for you until you take the following steps.

To fix overlapping noteheads in different layers

• Click the Mass Mover Tool l, and select the measures you want to edit. See SELECT-

ING MUSIC for more information.

• Choose Music Spacing Options from the Document Settings submenu of the Options 
Menu. The Music Spacing Options dialog box appears.

• Make sure that the Seconds checkbox is selected. You can also verify that other options you 
want included in spacing considerations are selected. See MUSIC SPACING OPTIONS DIALOG 
BOX for more information.

• Click OK. 

• Choose Apply Note Spacing from the Music Spacing submenu of the Mass Mover Menu. 
Your music will be spaced to avoid collisions between seconds in different layers. See MUSIC 
SPACING for more information on different types of music spacing.

Undo
Multiple Undo and Redo are available from the Edit Menu. Every action taken that modifies your 
music can be undone sequentially, in the reverse order in which you took action. The amount of 
changes that can be undone is only limited by the free disk space on your computer. This space is 
freed up when you quit Finale. These actions are also available from the Edit Menu Toolbar.

To undo the last change or a series of changes to your score
• Choose Undo from the Edit Menu or type ctrl-Z. You cannot select Undo if you have not 

performed any actions that modified the current document.

• To continue undoing changes, choose Undo from the Edit Menu or type ctrl-Z repeat-
edly. 

To undo a series of changes up to a specified point
• Choose Undo/Redo Lists from the Edit Menu or type ctrl-shift-Z. The Undo/Redo Lists 

dialog box appears.

• Select the last change that you want to undo from the list on the left. Finale will highlight 
all the actions that will be undone from the point you selected.

• Click OK. Finale will undo all the highlighted actions in the list.
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To re-apply changes to your score using redo
You cannot redo an action unless you have already selected Undo.

• Choose Redo from the Edit Menu or type ctrl-Y. 

• To continue redoing changes, choose Redo from the Edit Menu or type ctrl-Y repeatedly. 

To redo a series of changes up to a specified point
• Choose Undo/Redo Lists from the Edit Menu or type ctrl-shift-Z. The Undo/Redo Lists 

dialog box appears.

• Select the last change that you want to redo from the list on the right. Finale will highlight 
all the actions that will be redone from the point you selected.

• Click OK. Finale will redo all the highlighted actions in the list.

To allow undo actions previous to saving a file
• Choose Program Options from the Options Menu. The Program Options dialog box 

appears.

• Click Other Options. The Other Program Options dialog box appears.

• Select Allow Undo Past Save. This will allow Finale to continue tracking undo actions even 
though you have saved your document.

• Click OK twice. You return to the score.

Snapping to grids and guides
Snap to Grid and Snap to Guide is only available in Page View.

To turn on snapping of grids and guides
• Choose Snap to Grid or Snap to Guide from the Edit Menu. Choose the item again to 

deselect it and turn it off.

To turn on display of grids and guides
• Choose Show Grid or Show Guides from the View Menu. Choose Hide Grid or Hide 

Guides turn it off.

To snap items to a grid or guide
• Choose Page View from the View Menu. 

• Make sure that Snap to Grid or Snap to Guide is selected in the View Menu. See To set up 
a grid and To set up guides for information on creating and setting up guides and grids.

• Select a tool (such as the Expression Tool) that is enabled in the Items to Snap to Grid or 
Items to Snap to Guide dialog box. 

• Select a handle and move the item. The item will snap to the nearest grid point or guide line 
when you release the mouse button. Items will snap to a guide line only if they are moved to 
within the guides gravity zone. This is set up in the Grid/Guide Options dialog box.

To temporarily override the Snap function, press ctrl while dragging the item. Guides override 
the grid if both are being used and the item is dragged within the gravity zone of the guide.



Snapping to grids and guides 3-21      

OC

OC

ndex

Index

ext 
hapter

ext 
hapter

revious
hapter

revious
hapter
T

T

I

N
C

N
C

P
C

P
C

To set up a grid
• Choose Grid/Guide Options from the View Menu. The Grid/Guide Options dialog box 

appears. See GRID/GUIDE OPTIONS DIALOG BOX.

• Enter the density of the grid in the Grid Line Every text box. You can select the specific 
units.

• Enter the amount of the grid you would like to show in the Display One in text box. For 
example, entering a 1 would display every grid line. Entering a 2 would display every other 
grid line.

• Select the style of the grid lines from the Grid Line Style drop-down list. 

• Click Grid Color to set up the color of the grid. 

• Click on Items to Snap to Grid to select which items are affected by the Snap to Grid 
function. See ITEMS TO SNAP TO GRID DIALOG BOX for more details.

• Click Show Grid and Snap to Grid. This will ensure that the grid is displayed and in effect.

• Click OK. 

To set up guides
• Choose Grid/Guide Options from the View Menu. The Grid/Guide Options dialog box 

appears.

• Enter the size of the gravity zone around the guide in the Gravity Zone Size text box. You 
can select the specific units. The gravity zone is the space around the guide that will “capture” 
any item dragged into it and snap it to the guide.

• Select the style of the grid lines from the Guide Line Style drop-down list. 

• Click Guides Color to set up the color of the grid. 

• Click on Items to Snap to Guide to select which items are affected by the Snap to Guide 
function. See ITEMS TO SNAP TO GUIDE DIALOG BOX for more details.

• Click Show Guide and Snap to Guide. This will ensure that the guides are displayed and in 
effect.

• Click OK. 

• Make sure Show Rulers and Page View are selected in the View Menu. 

• Double-click in the ruler to create a guide. Click on the guide in the ruler and drag to move 
the guide. Click on the guide in the ruler and press delete to delete guide. Ctrl-click to select 
multiple guides.
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